Bug 1142588 - Search on usergroup page doesn't filter the specified string (w/wo quotes)
Summary: Search on usergroup page doesn't filter the specified string (w/wo quotes)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact: Adam Ruzicka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-17 05:23 UTC by Sachin Ghai
Modified: 2019-09-25 20:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
search on usergroup page doesn't filter the specified string (31.61 KB, application/octet-stream)
2014-09-17 05:23 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7494 None None None 2016-04-22 15:47:43 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2014-09-17 05:23:25 UTC
Created attachment 938335 [details]
search on usergroup page doesn't filter the specified string

Description of problem:
Automation tests were failing as UI doesn't search usergroup names properly. Initially I thought problem is only with utf8 and latin1 characters, issue is with alpha nd numeric strings too.

Version-Release number of selected component (if applicable):
Sat6 GA Z release
Satellite-6.0.4-RHEL-6-20140915.0

How reproducible:
always

Steps to Reproduce:
1. create usergroup with alpha, numeric, latin and utf8 chars
2. user searchbar on usergroup page to search/filter any one created in step1
3.

Actual results:
Search won't filter the given string

Expected results:
Search should filter the only specified string

Additional info:
no error in logs

Comment 2 Dominic Cleal 2014-09-17 11:44:15 UTC
Created redmine issue http://projects.theforeman.org/issues/7494 from this bug

Comment 3 Bryan Kearney 2015-08-25 18:07:44 UTC
Upstream bug component is Provisioning

Comment 4 Bryan Kearney 2016-03-07 13:01:55 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7494 has been closed
-------------
Shimon Shtein
Applied in changeset commit:35d6eb40a800b6f4ea04e53eb3bb9631504863db.

Comment 6 Adam Ruzicka 2016-06-27 11:07:25 UTC
VERIFIED.
Satellite 6.2 GA 17.0
foreman-1.11.0.39-1.el7sat.noarch

Followed instruction from comment #0, user groups are filtered as expected, no errors in the logs.

Comment 8 errata-xmlrpc 2016-07-27 08:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.