Bug 1142629 - [Edit VM] > Irrelevant and wrong pop-up Operation canceled while moving VM from cluster to cluster
Summary: [Edit VM] > Irrelevant and wrong pop-up Operation canceled while moving VM fr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Gilad Chaplik
QA Contact: Michael Burman
URL:
Whiteboard: sla
: 1145059 1156018 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-17 06:56 UTC by Michael Burman
Modified: 2016-02-10 20:19 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:07:11 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)
Screen shoot (1.91 MB, application/octet-stream)
2014-09-17 06:56 UTC, Michael Burman
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34157 master ABANDONED webadmin: Fixed VM moving between clusters error. Never
oVirt gerrit 34395 master MERGED webadmin: Fixed VM moving between clusters error. Never
oVirt gerrit 34513 ovirt-engine-3.5 MERGED webadmin: Fixed VM moving between clusters error. Never

Description Michael Burman 2014-09-17 06:56:20 UTC
Created attachment 938356 [details]
Screen shoot

Description of problem:
[Edit VM] > Irrelevant and wrong pop-up Operation canceled while moving VM from cluster to cluster. 
If you try to move VM from cluster to cluster- it can be from same cpu type(intel to intel), or with different cpu type(amd to intel), in both cases you get this message and in both cases operation doesn't really canceled, because the change is done, VM moved to other cluster and you can run the VM. 

Version-Release number of selected component (if applicable):
3.5.0-0.12.beta.el6ev

How reproducible:
always

Steps to Reproduce:
1.Edit VM and move it to other cluster, press 'ok' 
2.
3.

Actual results:
You will get this message: Operation Canceled
Error while executing action:

test1:

    ACTION_TYPE_CPU_PROFILE_NOT_MATCH_CLUSTER

After pressing close button, the VM moved to other cluster and can be run.
So operation doesn't really canceled.

Expected results:
- If i'm trying to move VM from cluster to cluster with same cpu type, i shouldn't see such error. 
- If you trying to move VM from cluster to cluster with different cpu's(amd>intel, or intel>amd)), should i get this message?? what is the right behavior? because as it seems, there is no problem to the VM to run on different cpu's type. And if so, in this case i shouldn't see this error.
- The message about Operation canceled don't really cancel the operation in both cases. Because the change is done in both cases and VM can run after this error message.
Additional info:

Comment 1 Gilad Chaplik 2014-10-28 07:28:55 UTC
*** Bug 1145059 has been marked as a duplicate of this bug. ***

Comment 2 Gilad Chaplik 2014-10-28 07:29:15 UTC
*** Bug 1156018 has been marked as a duplicate of this bug. ***

Comment 3 Roy Golan 2014-11-19 08:52:51 UTC
*** Bug 1158458 has been marked as a duplicate of this bug. ***

Comment 4 Ilanit Stein 2014-11-27 13:12:48 UTC
Eyal,

Look like this fix is already in vt10.1.
Can you please move this bug to on_qa?

Thanks,
Ilanit.

Comment 6 Michael Burman 2014-11-30 07:48:01 UTC
Verified on - 3.5.0-0.22.el6ev

Comment 7 Eyal Edri 2015-02-17 17:07:11 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.