Bug 114276 - Dynamically linked ghostscript is actually smaller
Summary: Dynamically linked ghostscript is actually smaller
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ghostscript   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL: http://www.camk.edu.pl/~chris/ghost-d...
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-26 07:46 UTC by Krzysio (Chris) Leszczynski
Modified: 2007-04-18 17:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 12:25:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Krzysio (Chris) Leszczynski 2004-01-26 07:46:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031030

Description of problem:
This not a bug.

I just read in the ghostscript.spec that
you don't ship /usr/lib/libgs because it is big (??) and nobody
uses it.  Well... none it's true. Actually stripped version of
libgs is smaller than statically linked ghostscript and yes,
many tools actually use libgs.  One of it is ps viewer from TeX-Live
distribution.

I have added a patch to ghostscript.spec.  It results in 3.5MB
libgs and 4kB /usr/bin/gs

Version-Release number of selected component (if applicable):
ghostscript-7.05

How reproducible:
Always

Steps to Reproduce:
  

Additional info:

Comment 1 Tim Waugh 2004-01-28 12:25:02 UTC
Thanks, fixed in CVS.  Will show up in next build after 7.07-18.


Note You need to log in before you can comment on or make changes to this bug.