Bug 1142769 - Update virt-viewer man page for oVirt connection support and fullscreen monitor mapping
Summary: Update virt-viewer man page for oVirt connection support and fullscreen monit...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jonathon Jongsma
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-17 11:34 UTC by CongDong
Modified: 2015-03-05 13:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: oVirt connection support and fullscreen monitor mapping were added without update the man page Consequence: users cannot find help info for oVirt connection and custom display->monitor mapping Fix: Virt Viewer and Remote Viewer man page have been updated Result: users can find help info for oVirt connection and custom display->monitor mapping
Clone Of:
Environment:
Last Closed: 2015-03-05 13:39:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0295 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2015-03-05 17:33:00 UTC

Description CongDong 2014-09-17 11:34:21 UTC
Description of problem:
virt-viewer support connect guest on rhevm with ovirt connection,
and can custom display->monitor mapping, but no manual in man page
and help info

Version-Release number of selected component (if applicable):
virt-viewer-0.6.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# man virt-viewer
cannot find ovirt connection and custom display->monitor mapping manual

2.# virt-viewer --help-all
cnanot find help info for ovirt connection and custom display->monitor mapping manual

3.

Actual results:
As description

Expected results:
can find manual for the new function in man page to tell how to connect guest via ovirt and custom display and monitor mapping

Additional info:

Comment 4 CongDong 2014-10-09 02:17:04 UTC
I can reproduce with virt-viewer-0.6.0-6.el7

VERIFY with virt-viewer-0.6.0-7.el7.x86_64:

Steps:
1. man virt-viewer
...
CONFIGURATION
       A small number of configuration options can be controlled by editing the settings file located in the user
       configuration directory:

           <USER-CONFIG-DIR>/virt-viewer/settings

       This file is a text file in INI format, with application options in the [virt-viewer] group and per-guest options
       in a group identified by the guest's UUID. The application options should not be edited manually. There is also a
       special [fallback] group which specifies options for all guests that don't have an explicit group.

       For each guest, the initial fullscreen monitor configuration can be specified by using the monitor-mapping key.
       This configuration only takes effect when the -f/--full-screen option is specified.

       The value of this key is a list of mappings between a guest display and a client monitor. Each mapping is separated
       by a semicolon character, and the mappings have the format <GUEST-DISPLAY-ID>:<CLIENT-MONITOR-ID>.

       For example, to map guest displays 1 and 2 to client monitors 2 and 3 for the guest with a UUID of
       e4591275-d9d3-4a44-a18b-ef2fbc8ac3e2, use:

           [e4591275-d9d3-4a44-a18b-ef2fbc8ac3e2]
           monitor-mapping=1:2;2:3
...

Can get the description for monitor-mapping function.

2. man remote-viewer
...
       To connect to a virtual machine named "toliara" on an oVirt server at example.org

          remote-viewer ovirt://[username@]example.org/toliara
...

Have an example of ovirt connection.

As the result, set VERIFIED.

Comment 6 errata-xmlrpc 2015-03-05 13:39:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html


Note You need to log in before you can comment on or make changes to this bug.