Bug 114282 - three compile time bugs
Summary: three compile time bugs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-pilot-conduits   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-26 10:30 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 17:57:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-01-26 10:30:48 UTC
Description of problem:

I just tried to compile package gnome-pilot-conduits-2.0.10-1, from Redhat
Fedora Core 1.

The compiler said

1.

time-conduit.c:201: warning: too many arguments for format

The source code is

	LOG ("synchronization to PDA = %d", t, err);

One % specifier, two parameters. Looks like a bug to me.

2.

AGBase64.c(194): warning #175: subscript out of range

The source code is

	*ob++ = ((inbuf [2] & 0x03) << 6) | (inbuf [3] & 0x3F);

but, earlier in the same function definition

    char inbuf [3];

so inbuf[ 3] doesn't exist. Clearly broken code. Suggest increase
size of inbuf to 4.


3.

mal-conduit.c(416): warning #1011: missing return statement at end of
non-void function "copy_from_pilot"

The source code is

static gint copy_from_pilot ( GnomePilotConduit *c, GnomePilotDBInfo
*dbi ) {
}

Normally, I'd suggest a return statement in here, but a quick grep of
the source code file suggest this is dead code. Suggest remove definition
of copy_from_pilot.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dave Malcolm 2004-09-21 17:57:50 UTC
re (1): this is still present in gnome-pilot-conduits-2.0.12;
time/time-conduit.c

re (2): also still present in version 2.0.12;
mal-conduit/mal/common/AGBase64.c: function GBase64Decode; I agree
with your suggestion

re (3): also still present in version 2.0.12;
mal-conduit/src/mal-conduit.c; I agree with your suggestion.

I've applied a patch and rebuilt into rawhide as
gnome-pilot-conduits-2.0.12-3

Reported upstream (with patch) here:
http://bugzilla.gnome.org/show_bug.cgi?id=153319


Note You need to log in before you can comment on or make changes to this bug.