Bug 1142844 - Katello-installer instructs the user to access the integrated capsule on port 9090, though it is unreachable.
Summary: Katello-installer instructs the user to access the integrated capsule on port...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1264151 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-17 13:55 UTC by Rich Jerrido
Modified: 2019-09-26 14:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:45:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13250 None None None 2016-01-15 21:51:57 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Rich Jerrido 2014-09-17 13:55:44 UTC
Description of problem:
At the end of installation, katello-installer instructs the user to access the integrated capsule on port 9090. However, if the user clicks/opens the link provided via the katello-installer command, they are presented a non-useful error page. 

Version-Release number of selected component (if applicable):
katello-installer-0.0.64-1.el6sat.noarch


How reproducible:
100%

Steps to Reproduce:
1. install Sat 6. The installer provides similar output to:

  Success!
  * Katello is running at https://satellite.example.org
      Default credentials are 'admin:*****'
  * Capsule is running at https://satellite.example.org:9090
  * To install additional capsule on separate machine continue by running:"

      capsule-certs-generate --capsule-fqdn "$CAPSULE" --certs-tar "~/$CAPSULE-certs.tar"


2. browse to https://satellite.example.org:9090/
3. user is presented with an error page stating:

"Sinatra doesn’t know this ditty.


Try this:
get '/' do
  "Hello World"
end"

Expected results:

If the integrated capsule is not meant to be interacted with directly over port 9090, then we should:

* Remove the 'Capsule is running.....' output from the installer
* Update the error page that is provided on port 9090 to something more informative, such as "the integrated capsule isn't meant to be interacted with directly"

Comment 1 RHEL Program Management 2014-09-17 14:03:09 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2015-10-16 00:04:23 UTC
*** Bug 1264151 has been marked as a duplicate of this bug. ***

Comment 7 Kedar Bidarkar 2016-03-31 20:47:30 UTC
For Sat6.2, s/katello-installer/foreman-installer/

After the foreman-installer is run,

out:   Success!
out:   * Katello is running at https://abc.redhat.com
out:       Initial credentials are admin / changeme
out:   * To install additional capsule on separate machine continue by running:
out: 
out:       capsule-certs-generate --capsule-fqdn "$CAPSULE" --certs-tar "~/$CAPSULE-certs.tar"
out: 
out:   The full log is at /var/log/foreman-installer/katello.log


VERIFIED With sat62-snap6

Comment 9 errata-xmlrpc 2016-07-27 08:45:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.