Bug 1142949 - ABRT is not downloading debuginfo packages
ABRT is not downloading debuginfo packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
21
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:7d63acb00f76527b3dd69edfbfe...
:
Depends On:
Blocks: F21AlphaFreezeException
  Show dependency treegraph
 
Reported: 2014-09-17 12:02 EDT by Moez Roy
Modified: 2014-10-30 04:48 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-30 04:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2014-09-17 12:02:32 EDT
Description of problem:
ABRT is not downloading debuginfo packages when I select don't upload core dumps.

Version-Release number of selected component:
gnome-abrt-0.3.7

Additional info:
reporter:       libreport-2.2.3
kernel:         3.16.2-301.fc21.x86_64
type:           libreport
Comment 1 Moez Roy 2014-09-17 13:12:00 EDT
--- Running analyze_LocalGDB ---
Analyzing coredump 'coredump'
Coredump references 105 debuginfo files, 105 of them are not installed
Setting up yum repositories
Looking for needed packages in repositories
Packages to download: 64
Downloading 137.90Mb, installed size: 659.41Mb. Continue? 'YES'
Downloading (1 of 64) libXrender-debuginfo-0.9.8-4.fc21.x86_64.rpm: 100%
Extracting cpio from /var/tmp/abrt-tmp-debuginfo-2014-09-17-10:08:55.18352/libXrender-debuginfo-0.9.8-4.fc21.x86_64.rpm
Can't extract package '/var/tmp/abrt-tmp-debuginfo-2014-09-17-10:08:55.18352/libXrender-debuginfo-0.9.8-4.fc21.x86_64.rpm'
Unpacking failed, aborting download...
Missing debuginfo file: /usr/lib/debug/.build-id/b3/c04de833cbdeab79ed9f702c1a85907b95f79a.debug
Missing debuginfo file: /usr/lib/debug/.build-id/84/547d466f75d441e58a068b695d343be930d79e.debug
Missing debuginfo file: /usr/lib/debug/.build-id/39/5c8d0d9a8c408eca1c755f68b8f42dc6289a4e.debug
Missing debuginfo file: /usr/lib/debug/.build-id/6b/1ef24711eef45300e3cc97b4b6202d8afb59f0.debug
Missing debuginfo file: /usr/lib/debug/.build-id/5d/5baf12f872020ac32a675ef0e2e1bb28f1f85d.debug
Missing debuginfo file: /usr/lib/debug/.build-id/51/b9b10d638f55a52cb3a3c4b69d6a81b36cbb61.debug
Missing debuginfo file: /usr/lib/debug/.build-id/c2/4caf10323a6c7662db5da9bc95342a56d46796.debug
Missing debuginfo file: /usr/lib/debug/.build-id/2d/c813a39be79e18d20c08adcfae1679fbd5b53e.debug
Missing debuginfo file: /usr/lib/debug/.build-id/7c/3a9b061269c3760288faa7e083e0044eff2962.debug
Missing debuginfo file: /usr/lib/debug/.build-id/fc/f47ea83ae2639c1bd265eec08999bd396333ae.debug
Missing debuginfo file: /usr/lib/debug/.build-id/c6/bce91d990bf33dbcb06f1f7ebdbbc7791fb0fe.debug
Missing debuginfo file: /usr/lib/debug/.build-id/f1/420de60af3d13a8119b2072e00310455eb7fae.debug
Missing debuginfo file: /usr/lib/debug/.build-id/0f/f5b2ab3f830d98f18108f5c2af047683fdda6f.debug
Missing debuginfo file: /usr/lib/debug/.build-id/ae/14845fbc34786ff3e1de10ba265f5567fa000b.debug
Missing debuginfo file: /usr/lib/debug/.build-id/65/d4d650dd534bb57dd400cc4cc8f69383a70164.debug
Missing debuginfo file: /usr/lib/debug/.build-id/2b/be4fed8b11e6e2abffddfaf48ced7886c6f471.debug
Missing debuginfo file: /usr/lib/debug/.build-id/17/4b09be9638081b68e009194a9f07f09cc38f9f.debug
Missing debuginfo file: /usr/lib/debug/.build-id/8b/8a995b1e1c10638ebe9d9b0162b8b7a8954367.debug
Missing debuginfo file: /usr/lib/debug/.build-id/d1/51639d965a762de1202ec166f53101a0bee927.debug
Missing debuginfo file: /usr/lib/debug/.build-id/35/5c3bfef29b95e5e6eba07ef0ed5468cb05e325.debug
Missing debuginfo file: /usr/lib/debug/.build-id/5e/7fc4faae5dcb80e0f3c52ce0d6d1044a93fe63.debug
Missing debuginfo file: /usr/lib/debug/.build-id/15/bb6aaae5d5ad3270ba81df4ddb6495c891c459.debug
Missing debuginfo file: /usr/lib/debug/.build-id/6f/b42a8dd13e63b48f55280dc84845cf2fe4dc2b.debug
Missing debuginfo file: /usr/lib/debug/.build-id/ac/64acb0fc32d04502b8659c1029a03e736a992a.debug
Missing debuginfo file: /usr/lib/debug/.build-id/f5/9fab48c43b53a4434c031b3cbec21c4f1cbb3a.debug
Missing debuginfo file: /usr/lib/debug/.build-id/29/28c4ef9b3e49969049fda68f79aa149fe32ee8.debug
Missing debuginfo file: /usr/lib/debug/.build-id/3a/ac4576a3161b355a69c051bc072bb944131148.debug
Missing debuginfo file: /usr/lib/debug/.build-id/92/05ac0e511dc820e2624c1d37571b0ec5235097.debug
Missing debuginfo file: /usr/lib/debug/.build-id/6c/068ba20ebd58d0f9df13f38ee548d2f80a114f.debug
Missing debuginfo file: /usr/lib/debug/.build-id/ce/69ad73dc94c290aa4bc52aca1a2a63e2774d74.debug
Missing debuginfo file: /usr/lib/debug/.build-id/5e/a1e2d5cdf6c969f3d86d37b08503a28f119a51.debug
Missing debuginfo file: /usr/lib/debug/.build-id/da/92b7e8f4532fbf069762834dc9bd72c6932a80.debug
Missing debuginfo file: /usr/lib/debug/.build-id/87/3b891cb6363da119e57543fe53b2c0dcd9df36.debug
Missing debuginfo file: /usr/lib/debug/.build-id/04/800eca8a357c9dc19cea69d4bb4efbc9e0c8f5.debug
Missing debuginfo file: /usr/lib/debug/.build-id/93/653839cef0ecba49b7dda77d4a02a8b67f11c6.debug
Missing debuginfo file: /usr/lib/debug/.build-id/80/5974224f8fad75674bd6561c12d9d18e77a499.debug
Missing debuginfo file: /usr/lib/debug/.build-id/05/a72b679cb14e5bc18b665e037a7c6678f6b35b.debug
Missing debuginfo file: /usr/lib/debug/.build-id/7e/21799e76cf5df83890262b1223e4270120afa1.debug
Missing debuginfo file: /usr/lib/debug/.build-id/39/2dda15a02531f14f3da83cb8e645fafb51762a.debug
Missing debuginfo file: /usr/lib/debug/.build-id/2f/a71712bc27a36233481050cc9c8d09674a2797.debug
Missing debuginfo file: /usr/lib/debug/.build-id/8b/c82b3259937f42df03a2b9d5fe446d12cf6587.debug
Missing debuginfo file: /usr/lib/debug/.build-id/fa/4f7fc4fbe90b86e28922ee325018376b5c9495.debug
Missing debuginfo file: /usr/lib/debug/.build-id/d2/f22d2c1664b0adaf48a62744c3b3b3a9d55776.debug
Missing debuginfo file: /usr/lib/debug/.build-id/d9/4de8d62bd6e8e0928c7155c9cfe00a8082421e.debug
Missing debuginfo file: /usr/lib/debug/.build-id/9c/d81d100b1a3a82b967ab5afadf3b6e1abb11f8.debug
Missing debuginfo file: /usr/lib/debug/.build-id/58/9585843722eea058f1bfdb6ae953980d18824f.debug
Missing debuginfo file: /usr/lib/debug/.build-id/82/f256f2f02ef6ff627e11ea01753800b6a5e1a9.debug
Missing debuginfo file: /usr/lib/debug/.build-id/61/bb424acca0e0668344460e93d03945102c7415.debug
Missing debuginfo file: /usr/lib/debug/.build-id/3e/d99c221f3cab34f63f33379bbd1fe5a832bf90.debug
Missing debuginfo file: /usr/lib/debug/.build-id/39/f65d7a1922278820c5e03841297e77d015e681.debug
Missing debuginfo file: /usr/lib/debug/.build-id/ef/2d34e606701521c11d8a3ed49c1f81abc957c3.debug
Missing debuginfo file: /usr/lib/debug/.build-id/fe/cc4c11e72719de2f77e2ec76c76d291a79d552.debug
Missing debuginfo file: /usr/lib/debug/.build-id/c2/f744eb1b3f56b21ee6b1dfa86fd999ec127cbe.debug
Missing debuginfo file: /usr/lib/debug/.build-id/88/40732bed1e12d53ab4e7e5254828913dfa00c9.debug
Missing debuginfo file: /usr/lib/debug/.build-id/91/c4c4f49ba7cd129f4e1d7d75d208041b45a82b.debug
Missing debuginfo file: /usr/lib/debug/.build-id/77/846faee813bcaaf4babda207475fea154cfe31.debug
Missing debuginfo file: /usr/lib/debug/.build-id/78/7f26fadfdd066e2a934887b73dac69cff27fb6.debug
Missing debuginfo file: /usr/lib/debug/.build-id/96/fdbbfb95b6d5fe2435d2c568e128e20d5a385f.debug
Missing debuginfo file: /usr/lib/debug/.build-id/63/1200e678107d0c1a4e9363435699460dce455c.debug
Missing debuginfo file: /usr/lib/debug/.build-id/91/44e9c5c74edbdccfdc0a147a9874f9e5fcbcd0.debug
Missing debuginfo file: /usr/lib/debug/.build-id/eb/7700e02ba9f8a9e149c122defc8b3b23eabeb4.debug
Missing debuginfo file: /usr/lib/debug/.build-id/18/962f69d5207340915f80df1b99374b955d5506.debug
Missing debuginfo file: /usr/lib/debug/.build-id/08/17628803679261ee8d69dad30a533ceec26490.debug
Missing debuginfo file: /usr/lib/debug/.build-id/a2/b3afbf3d6daf87b2613f9a85e7ae1069f3bd17.debug
Missing debuginfo file: /usr/lib/debug/.build-id/83/44b819764dbb8d344658ba22e9ba13ae079b70.debug
Missing debuginfo file: /usr/lib/debug/.build-id/a3/7396cccb9c4af91539cc7fbdfb3e8e47614812.debug
Missing debuginfo file: /usr/lib/debug/.build-id/d7/f37635cf735304416042d4436946817c3fdd7d.debug
Missing debuginfo file: /usr/lib/debug/.build-id/3e/fc06bd68793f68f24c14857e376e7a83df70f1.debug
Missing debuginfo file: /usr/lib/debug/.build-id/62/91f3d03bf6d7c97ec6e0dc07a569310d7b05c1.debug
Missing debuginfo file: /usr/lib/debug/.build-id/b8/5bca5360a1984e73bd118b9d36524023ff2c9c.debug
Missing debuginfo file: /usr/lib/debug/.build-id/ef/fd1da42ed1363436d6586b925749382ad9be5e.debug
Missing debuginfo file: /usr/lib/debug/.build-id/1b/e52e9262af196416fc57fa12ef6860691fb9c3.debug
Missing debuginfo file: /usr/lib/debug/.build-id/df/90ea577a0ff2be5d37bb91fdfe55db0a86e2bb.debug
Missing debuginfo file: /usr/lib/debug/.build-id/56/fe32b59bd6d7a74e669fff875f05249b5d7277.debug
Missing debuginfo file: /usr/lib/debug/.build-id/e5/75413f490e3a0e6bdd6e3201e102a7a4bcbfaa.debug
Missing debuginfo file: /usr/lib/debug/.build-id/68/31c3e29c1c841264baccaa53f4f81bd1771515.debug
Missing debuginfo file: /usr/lib/debug/.build-id/d0/fa3f5c7823a82385806bd9cf50cfa9f0ea9464.debug
Missing debuginfo file: /usr/lib/debug/.build-id/03/4873be504e603ce9a77e6d18cdcbc909c15699.debug
Missing debuginfo file: /usr/lib/debug/.build-id/6b/b7ebdb33a6bcd172716f03e6637d53c482c04d.debug
Missing debuginfo file: /usr/lib/debug/.build-id/c3/0f70d74fe058627d84c981dbb9afcd01ba06e4.debug
Missing debuginfo file: /usr/lib/debug/.build-id/c7/f58ee65ef91bba50ec4b71f961098607109a07.debug
Missing debuginfo file: /usr/lib/debug/.build-id/84/31cadad5a88164a64b786585f23e79dc235e74.debug
Missing debuginfo file: /usr/lib/debug/.build-id/b5/5934a5d932665fa58d1cedb541f6b0aa694b3b.debug
Missing debuginfo file: /usr/lib/debug/.build-id/7c/e515d931500927d68ba052fdd9ecd771189fe5.debug
Missing debuginfo file: /usr/lib/debug/.build-id/17/b0f278fe008ae4a5e7accaa43a2769d7e27b09.debug
Missing debuginfo file: /usr/lib/debug/.build-id/5e/066f4ab8df1cec88c5c1783717a1e8275240c1.debug
Missing debuginfo file: /usr/lib/debug/.build-id/3f/ca7482177422c64c143a8254c1341d6aae61bb.debug
Missing debuginfo file: /usr/lib/debug/.build-id/3b/cf19c61c951e8d360a4756f591bf3442817a0e.debug
Missing debuginfo file: /usr/lib/debug/.build-id/b5/4a85b5b5784d541297ea662aba22d458b98d53.debug
Missing debuginfo file: /usr/lib/debug/.build-id/b1/cc237f45ae757ac0d8380e4e5c69eaf2ea21dc.debug
Missing debuginfo file: /usr/lib/debug/.build-id/4d/d87dcc39c86a0377fea7d1fd84412ae2dcf8c6.debug
Missing debuginfo file: /usr/lib/debug/.build-id/d2/ea5e5e103f75dc689bdd466135acd8d9ce66ee.debug
Missing debuginfo file: /usr/lib/debug/.build-id/7a/b8348256eefb377b07be64b1bf7a3723436384.debug
Missing debuginfo file: /usr/lib/debug/.build-id/a0/030bfbee09c56e24272d442dfa67f05402e776.debug
Missing debuginfo file: /usr/lib/debug/.build-id/85/6eb4bebac884da5531071298dc23551f9c7795.debug
Missing debuginfo file: /usr/lib/debug/.build-id/0e/946bf18aeab52b5f3ef7f912b4b739a5da9010.debug
Missing debuginfo file: /usr/lib/debug/.build-id/47/13b3e13ebb6c9839391c41e629695dacb5a48c.debug
Missing debuginfo file: /usr/lib/debug/.build-id/65/453eeaaccee981cc6b42673f5420d3ed16369d.debug
Missing debuginfo file: /usr/lib/debug/.build-id/a6/72b0dfc2457bcca115c68d9941909024f0ea27.debug
Missing debuginfo file: /usr/lib/debug/.build-id/63/665249f4b786d55ea411e249f0bc2ceb6bbdd2.debug
Missing debuginfo file: /usr/lib/debug/.build-id/f3/3582298c984486d17a35b0646752447bef6761.debug
Missing debuginfo file: /usr/lib/debug/.build-id/87/5fc06fbf1c810a9a6468f8bf6c43e549bc375b.debug
Missing debuginfo file: /usr/lib/debug/.build-id/9d/76436fc9eb0f2b4e813bc995aae1bd1b5e846a.debug
Missing debuginfo file: /usr/lib/debug/.build-id/84/0db0fd4f75d2429363c2203a254a83ce0781c0.debug
Missing debuginfo file: /usr/lib/debug/.build-id/76/bb4ebbcef6629fcae0c55caabbd1c2b7307119.debug
Generating backtrace
Backtrace is generated and saved, 33170 bytes
Looking for similar problems in bugzilla
Comment 2 Moez Roy 2014-09-17 13:39:26 EDT
Proposing as Alpha Blocker Bug because if people cannot use ABRT to report bugs found in the Alpha release whats the point of the Alpha release?

Failing to block Alpha release requesting this bug as a Freeze exception for the Alpha release.
Comment 3 Adam Williamson 2014-09-17 13:46:47 EDT
-1 blocker, this is not in the criteria. We require crash reporting to work for the *installer*, but for post-install environment bugs can be fixed with updates.
Comment 4 Mike Ruckman 2014-09-17 13:50:56 EDT
-1 Blocker
Comment 5 Stephen Gallagher 2014-09-17 13:54:30 EDT
-1 blocker, it can be fixed in the installed system with an update and does not violate any criteria.
Comment 6 Moez Roy 2014-09-17 13:56:03 EDT
(In reply to Adam Williamson (Red Hat) from comment #3)
> -1 blocker, this is not in the criteria. We require crash reporting to work
> for the *installer*, but for post-install environment bugs can be fixed with
> updates.


What about the people testing the Final Alpha release using only the Live CD? They will not install the updates.
Comment 7 Adam Williamson 2014-09-17 14:28:40 EDT
If you need local debuginfos you're unlikely to have sufficient RAM to be able to 'install' them all to the local system. In most cases remote retracing should work OK.
Comment 8 Adam Williamson 2014-09-17 15:03:00 EDT
I can confirm this bug, BTW, reproduced both live and post-install. It happens also in abrt-cli . I believe the responsible code is part of libreport-python - specifically we're hitting a failure of unpack_rpm() in reportclient/debuginfo.py . Re-assigning.
Comment 9 Jakub Filak 2014-09-17 15:16:58 EDT
(In reply to Adam Williamson (Red Hat) from comment #8)
> I can confirm this bug, BTW, reproduced both live and post-install. It
> happens also in abrt-cli . I believe the responsible code is part of
> libreport-python - specifically we're hitting a failure of unpack_rpm() in
> reportclient/debuginfo.py . Re-assigning.

Yes, you are right, but the root cause is in rpm2cpio which exits with 1 because headerGetNumber(h, RPMTAG_LONGARCHIVESIZE) returns an invalid number.

$ rpm -q rpm
rpm-4.12.0-0.rc1.2.fc21.x86_64

I was playing with:

https://kojipkgs.fedoraproject.org//packages/will-crash/0.8/1.fc21/x86_64/will-crash-debuginfo-0.8-1.fc21.x86_64.rpm

where:
compr == "xz"
rpmi_flags = "r.xz"
headerGetNumber(h, RPMTAG_LONGARCHIVESIZE) == 151902

but payload size is 152028.

Re-assigning.
Comment 10 Panu Matilainen 2014-09-18 03:28:11 EDT
Seems RPMTAG_ARCHIVESIZE disagrees with the actual payload size on all packages generated with rpm 4.12. What fun...
Comment 11 Fedora Update System 2014-09-18 08:14:20 EDT
rpm-4.12.0.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rpm-4.12.0.1-1.fc21
Comment 12 Panu Matilainen 2014-09-18 08:17:53 EDT
So... the update does two things:
1) it fixes the build-time calculation of the archive size tag
2) it adds a temporary workaround to rpm2cpio so it doesn't exit with an error on affected packages (which are plenty)

2) is unfortunate but unavoidable, unless there's another mass-rebuild for f21...
Comment 13 Mike Ruckman 2014-09-18 15:54:15 EDT
Discussed in 2014-09-18 Go/No-Go meeting. Voted as a RejectedBlocker because "This bug violates no criteria and is easily remedied with an update post-install."
Comment 14 Fedora Update System 2014-09-27 06:10:43 EDT
rpm-4.12.0.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.