Bug 1142984 - Unable to Deploy EAP Bundles
Summary: Unable to Deploy EAP Bundles
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ER03
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: JON3-10, PRODMGT-544
TreeView+ depends on / blocked
 
Reported: 2014-09-17 16:47 UTC by Matt Mahoney
Modified: 2014-12-11 14:05 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:05:11 UTC


Attachments (Terms of Use)

Description Matt Mahoney 2014-09-17 16:47:47 UTC
Description of problem:
Attempting to Deploy a bundle to any EAP type (Standalone, Domain Ctlr) fails with the following message:

"The underlying server does not support the patch command. Cannot perform the patch operation."

Version-Release number of selected component (if applicable):
ER03

How reproducible:


Steps to Reproduce:
1. Create a Group with a single EAP Standalone server
2. Upload an EAP Patch
3. Attempt to Deploy to the Group with Single EAP

Actual results:
Deploy does not take place

Expected results:
Deploy should be successfull

Additional info:

Comment 4 Michael Burman 2014-09-18 09:03:34 UTC
commit 3d3c55928612ba7c55a2c844a58df66cdac362f8
Author: Michael Burman <miburman@redhat.com>
Date:   Thu Sep 18 12:02:56 2014 +0300

    [BZ 1142984] Fix parsing of output from help --commands

Comment 5 Michael Burman 2014-09-18 09:04:10 UTC
The commit is in master

Comment 7 Simeon Pinder 2014-09-18 21:38:53 UTC
This is fixed with commit:17b2d55abfe2 to rhq.git and available for test with the EAP Plugin Pack from this brew build: 
https://brewweb.devel.redhat.com//buildinfo?buildID=386451

Moving this to ON_QA.


Note You need to log in before you can comment on or make changes to this bug.