Bug 114334 - libaio does not compile on s390
libaio does not compile on s390
Status: CLOSED DUPLICATE of bug 114335
Product: Red Hat Linux
Classification: Retired
Component: libaio (Show other bugs)
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-01-26 14:06 EST by Janet Morgan
Modified: 2007-04-18 13:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Janet Morgan 2004-01-26 14:06:18 EST
Description of problem:

Error compiling libaio-0.3.96 on s390 (see "Actual results" below).
The problem is that src/io_queue_wait.c is including 
<linux/types.h> which is a system header file.
src/io_queue_wait.c should instead include <sys/types.h>.
Also, while that fixes the compilation error, should src/libaio.h also 
be changed to include <sys/types.h> instead of <asm/types.h> ?

Version-Release number of selected component (if applicable):

How reproducible:
Compile libaio on s390.

Steps to Reproduce:
1.  As above
Actual results:

<wjyoung@lyta> make
make[1]: Entering directory `/tmp/libaio-0.3.96/src'
cc -nostdlib -nostartfiles -Wall -I. -g -fomit-frame-pointer -O2 -fPIC
-c -o io_queue_init.ol io_queue_init.c
cc -nostdlib -nostartfiles -Wall -I. -g -fomit-frame-pointer -O2 -fPIC
-c -o io_queue_release.ol io_queue_release.c
cc -nostdlib -nostartfiles -Wall -I. -g -fomit-frame-pointer -O2 -fPIC
-c -o io_queue_wait.ol io_queue_wait.c
In file included from /usr/include/asm/posix_types.h:59,
                 from /usr/include/linux/posix_types.h:46,
                 from /usr/include/linux/types.h:4,
                 from io_queue_wait.c:20:
/usr/include/asm/bitops.h:41: #error "bitops won't work without
make[1]: *** [io_queue_wait.ol] Error 1
make[1]: Leaving directory `/tmp/libaio-0.3.96/src'
make: *** [all] Error 2

Expected results:
libaio should compile cleanly.

Additional info:
Comment 1 Janet Morgan 2004-01-26 14:11:31 EST

*** This bug has been marked as a duplicate of 114335 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.