Bug 114344 - No apparent sign of support for YP in installer
No apparent sign of support for YP in installer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 17:28 EST by Bryan O'Sullivan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-30 09:10:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2004-01-26 17:28:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031015 Firebird/0.7

Description of problem:
I just did a clean network-based install of FC1 0.96 for AMD64 onto a
system, and found that the installer did not prompt me for any YP
(NIS) related information during the install process, unlike RH9 and
RHEL3.

This meant that the machine required a lot of manual reconfiguration
after it came up.  I had to do roughly the following:

- edit /etc/yp.conf
- edit /etc/sysconfig/network to add a NISDOMAIN entry
- edit /etc/nsswitch.conf to tell it to use YP where appropriate
- chkconfig ypbind on
- service ypbind start
- service autofs start
- service sshd restart (to get it to find the changes)

This is much more work than I'd have expected, which I'll have to
automate in my Kickstart scripts now.  Quite a regression from earlier
Red Hat releases, which mostly just worked in this regard.

Version-Release number of selected component (if applicable):
FC1 0.96 for AMD64

How reproducible:
Always

Steps to Reproduce:
1. Install FC1.
2. Try to log into an account served up using YP and automount maps.
3. Smoosh.  Crash.  Blam.  Much fixing by hand.
    

Expected Results:  The installer used to ask me about NIS and so on,
and do some sensible configuration for me.  It no longer does.
Comment 1 Bryan O'Sullivan 2004-01-26 17:29:26 EST
This obviously isn't specifically a ypbind bug, since it's also
anaconda-related, but it spans several components, so I couldn't think
of a more suitable place to put it.

I'd expect the same problems to occur with the x86 installer, but I've
only done upgrades from RH9, not clean installs, with that.
Comment 2 Jeremy Katz 2004-04-30 09:10:40 EDT
Similar to RHEL3 (but changed from Red Hat Linux 9), you set this in
firstboot when you add a user there.

Note You need to log in before you can comment on or make changes to this bug.