Bug 11436 - ifdown hangs on Multia
Summary: ifdown hangs on Multia
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 17009 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-16 08:38 UTC by Bas Vermeulen
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-19 21:35:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bas Vermeulen 2000-05-16 08:38:47 UTC
When bringing down an interface with ifdown, it hangs on the
check_default_route in ifdown-post. Afaics this evaluates to the
following code:

return `/sbin/route -n|gawk 'BEGIN{r=1} $3=="0.0.0.0" && $4=="UG" {r=0}
END{print r}'`

When I do this at the prompt, I can see the gawk call taking 99% of the
cpu time. I'm not sure what causes this, but it is 99% reproducable on
this particular box. I haven't seen it on my Intel boxes yet.

Information on the machine:

DEC Multia (ev4 166MHz (UDB))
32 MB RAM
300 MB SCSI HD

Comment 1 Bill Nottingham 2000-05-16 16:17:59 UTC
What happens if you link awk to mawk?

Comment 2 mchampig 2000-05-19 21:35:59 UTC
I hope this isn't the same problem the Jensen was having (also another EV4
based box). Jensen's hang when using gawk but mawk works fine. I think it
was traced to a floating point emulation problem in the kernel. My Multia
is a slightly newer EV45 (233Mhz) and doesn't have this problem.

Comment 3 Bill Nottingham 2000-07-20 07:21:40 UTC
closed, lack of input from original poster.

Comment 4 Bill Nottingham 2000-08-30 20:05:45 UTC
*** Bug 17009 has been marked as a duplicate of this bug. ***

Comment 5 Simon Hill 2000-09-01 04:18:55 UTC
This bug is fixed by EV4 FPE kernel patch, see bug #17163.


Note You need to log in before you can comment on or make changes to this bug.