This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 114366 - 'make modules' fails with strange compiler error when compiling custom kernel
'make modules' fails with strange compiler error when compiling custom kernel
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 07:11 EST by starlight
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
.config (18.26 KB, text/plain)
2004-01-27 07:16 EST, starlight
no flags Details
'make depend' output (158.67 KB, text/plain)
2004-01-27 07:18 EST, starlight
no flags Details
'make bzImage' output (157.12 KB, text/plain)
2004-01-27 07:18 EST, starlight
no flags Details
'make modules' output (8.07 KB, text/plain)
2004-01-27 07:19 EST, starlight
no flags Details
output from 'rpm -qa' (6.31 KB, text/plain)
2004-01-27 07:24 EST, starlight
no flags Details

  None (edit)
Description starlight 2004-01-27 07:11:56 EST
From Bugzilla Helper:

Description of problem:
Compiling custom kernel.  Configuration file is attached below.  
'drivers/block/loop.c' fails with bizarre error that may be a compiler 
problem:

/usr/src/linux-2.4.22-1.2149.nptl/include/asm/processor.h:60: field 
`loops_per_jiffy_R_ver_str' declared as a function

Referenced line appears thus in gcc32 -E output:

   unsigned long loops_per_jiffy_R_ver_str(ba497f13);

Original looks like this:

   unsigned long loops_per_jiffy;

Can't find any #define macros that come close to causing this.


Version-Release number of selected component (if applicable):
kernel-source-2.4.22-1.2149.nptl, gcc32-3.2.3-6, gcc-3.3.2-1

How reproducible:
Always

Steps to Reproduce:
cd /usr/src/linux-2.4.22-1.2149.nptl
make config
make dep
make bzImage
make modules
Comment 1 starlight 2004-01-27 07:16:44 EST
Created attachment 97271 [details]
.config
Comment 2 starlight 2004-01-27 07:18:03 EST
Created attachment 97272 [details]
'make depend' output
Comment 3 starlight 2004-01-27 07:18:45 EST
Created attachment 97273 [details]
'make bzImage' output
Comment 4 starlight 2004-01-27 07:19:22 EST
Created attachment 97274 [details]
'make modules' output
Comment 5 starlight 2004-01-27 07:21:59 EST
Forgot:

Same thing happens with original Fedora base images from 11/2003 and 
with system patched to latest version.
Comment 6 starlight 2004-01-27 07:24:25 EST
Created attachment 97275 [details]
output from 'rpm -qa'
Comment 7 starlight 2004-01-28 06:43:35 EST
I just successfully downloaded and custom-built kernel
2.6.1 from kernel.org.  Just had to remove kudzu from
the rc starups and it works great.

Don't care about this bug anymore.
Comment 8 Dave Jones 2004-06-19 11:33:09 EDT

*** This bug has been marked as a duplicate of 126342 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:00:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.