Bug 1143814 - [abrt] freecad: DraftSnap.py:578:snapToPolar:Exception: Both points are equal
Summary: [abrt] freecad: DraftSnap.py:578:snapToPolar:Exception: Both points are equal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c9cc8d0a69aa0d3b50688117931...
: 1162818 1169548 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 04:39 UTC by Marcus
Modified: 2014-12-06 10:31 UTC (History)
4 users (show)

Fixed In Version: freecad-0.14-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-27 08:37:41 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.38 KB, text/plain)
2014-09-18 04:39 UTC, Marcus
no flags Details
File: environ (1.92 KB, text/plain)
2014-09-18 04:39 UTC, Marcus
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeCAD 1757 None None None Never

Description Marcus 2014-09-18 04:39:37 UTC
Version-Release number of selected component:
freecad-0.14-2.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/FreeCAD
executable:     /usr/bin/FreeCAD
kernel:         3.16.2-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
DraftSnap.py:578:snapToPolar:Exception: Both points are equal

Traceback (most recent call last):
  File "/usr/lib64/freecad/Mod/Draft/DraftTools.py", line 2281, in action
    self.point,ctrlPoint,info = getPoint(self,arg)
  File "/usr/lib64/freecad/Mod/Draft/DraftTools.py", line 131, in getPoint
    point = FreeCADGui.Snapper.snap(args["Position"],lastpoint=last,active=amod,constrain=cmod,noTracker=noTracker)
  File "/usr/lib64/freecad/Mod/Draft/DraftSnap.py", line 214, in snap
    point,eline = self.snapToPolar(point,lastpoint)
  File "/usr/lib64/freecad/Mod/Draft/DraftSnap.py", line 578, in snapToPolar
    de = Part.Line(last,last.add(v)).toShape()
Exception: Both points are equal

Local variables in innermost frame:
a: 45
last: Vector (-1.598287106195417e+17, -6.867849111557007, 0.0)
point: Vector (-1.570246601721636e+17, -6.696150541305542, 0.0)
self: <DraftSnap.Snapper instance at 0x39fff38>
vecs: [Vector (1.0, 6.123233995736766e-17, 0.0), Vector (-1.0, -6.123233995736766e-17, -0.0), Vector (0.0, 1.0, 0.0), Vector (-0.0, -1.0, -0.0), Vector (0.7071067811865476, 0.7071067811865475, 0.0), Vector (-0.7071067811865476, -0.7071067811865475, -0.0), Vector (-0.7071067811865475, 0.7071067811865476, 0.0), Vector (0.7071067811865475, -0.7071067811865476, -0.0)]
v: Vector (1.0, 6.123233995736766e-17, 0.0)
ax: [Vector (1.0, 6.123233995736766e-17, 0.0), Vector (0.0, 1.0, 0.0), Vector (0.0, 0.0, 1.0)]

Comment 1 Marcus 2014-09-18 04:39:40 UTC
Created attachment 938742 [details]
File: backtrace

Comment 2 Marcus 2014-09-18 04:39:41 UTC
Created attachment 938743 [details]
File: environ

Comment 3 Richard Shaw 2014-09-18 21:18:16 UTC
Reported upstream.

Comment 4 Fedora Update System 2014-11-17 20:24:25 UTC
freecad-0.14-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/freecad-0.14-4.fc20

Comment 5 Fedora Update System 2014-11-17 20:24:31 UTC
freecad-0.14-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/freecad-0.14-4.fc21

Comment 6 Fedora Update System 2014-11-18 12:16:31 UTC
Package freecad-0.14-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freecad-0.14-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15281/freecad-0.14-4.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-11-27 08:37:41 UTC
freecad-0.14-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Marcus 2014-11-28 23:45:47 UTC
Works perfectly.
Thanks to all involved in fixing this.
Great product.

Comment 9 Richard Shaw 2014-12-02 02:13:20 UTC
*** Bug 1169548 has been marked as a duplicate of this bug. ***

Comment 10 Richard Shaw 2014-12-02 14:45:18 UTC
*** Bug 1162818 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2014-12-06 10:31:51 UTC
freecad-0.14-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.