Bug 1143822 - Do not set default switches in Test::Harness
Summary: Do not set default switches in Test::Harness
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-ExtUtils-MakeMaker
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL: https://koji.fedoraproject.org/koji/t...
Whiteboard:
Depends On:
Blocks: 1127476 1127477
TreeView+ depends on / blocked
 
Reported: 2014-09-18 05:31 UTC by Jitka Plesnikova
Modified: 2014-09-30 01:59 UTC (History)
3 users (show)

Fixed In Version: perl-ExtUtils-MakeMaker-6.64-4.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-28 04:27:22 UTC


Attachments (Terms of Use)
Patch with fix (961 bytes, patch)
2014-09-18 05:31 UTC, Jitka Plesnikova
no flags Details | Diff

Description Jitka Plesnikova 2014-09-18 05:31:30 UTC
Created attachment 938748 [details]
Patch with fix

I tried to update perl-Syntax-Highlight-Engine-Kate to version 0.09, but it failed with following error

PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t
    
    #   Failed test 'warn'
    #   at t/02-perl.t line 31.
    # found carped warning: undefined language: 'Klingon' at t/02-perl.t line 26.
    # found warning: Use of uninitialized value in concatenation (.) or string at /builddir/build/BUILD/Syntax-Highlight-Engine-Kate-0.09/blib/lib/Syntax/Highlight/Engine/Kate/Template.pm line 499.
    # found carped warning: cannot create plugin for language 'Klingon'
    # expected to find carped warning: (?^:undefined language: 'Klingon')
    # expected to find carped warning: (?^:cannot create plugin for language 'Klingon')
    # Looks like you failed 1 test of 2.
#   Failed test 'klingon'
#   at t/02-perl.t line 33.
[..]    


The source of the issue is old version of perl-ExtUtils-MakeMaker, which allows to set default switches (e.g. -w) in Test::Harness.
It was fixed at version 6.77_7

commit 37c20b4442e87cb678301cf742604f23a8d30a82
Author:     Ricardo Signes <rjbs@cpan.org>
AuthorDate: Sat Sep 21 10:12:51 2013 +0900
Commit:     Ricardo Signes <rjbs@cpan.org>
CommitDate: Sat Sep 21 10:12:51 2013 +0900

    do not set default switches in Test::Harness; not even -w


New test command generated by updated EU::MM passed.

PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/02-perl.t
t/02-perl.t .. ok   
All tests successful.


Fedora 19 is also affected.

The patch works for both (F19 and F20).

Comment 1 Fedora Update System 2014-09-18 07:30:59 UTC
perl-ExtUtils-MakeMaker-6.64-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-ExtUtils-MakeMaker-6.64-4.fc19

Comment 2 Fedora Update System 2014-09-18 08:02:05 UTC
perl-ExtUtils-MakeMaker-6.72-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-ExtUtils-MakeMaker-6.72-3.fc20

Comment 3 Fedora Update System 2014-09-19 10:10:54 UTC
Package perl-ExtUtils-MakeMaker-6.72-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-ExtUtils-MakeMaker-6.72-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11034/perl-ExtUtils-MakeMaker-6.72-3.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-09-28 04:27:22 UTC
perl-ExtUtils-MakeMaker-6.72-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2014-09-30 01:59:50 UTC
perl-ExtUtils-MakeMaker-6.64-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.