Bug 114387 - copy&paste from message text strips linefeeds
copy&paste from message text strips linefeeds
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 10:42 EST by Osma Ahvenlampi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 16:16:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Osma Ahvenlampi 2004-01-27 10:42:28 EST
Description of problem:
When copying text via the clipboard from a received message (either in
preview or message view window) to anywhere else (including evo's
message composer or gedit), linefeeds are stripped out from the text
copied.

Version-Release number of selected component (if applicable):
evolution 1.4.5-7, gtkhtml3 3.0.9-5

How reproducible:
always

Steps to Reproduce:
1. open any text/plain message with more than two paragraphs
2. paint and copy text
3. paste said text to evo composer or gedit
  
Actual results:
lines are merged, ie

line1 has some text
line2 has more text

becomes

line1 has some textline2 has more text

Expected results:
text should be copied as-is, including linefeeds

Additional info:
Comment 1 Bart Martens 2004-01-28 14:45:59 EST
Confirming this bug. I just copied a message with line breaks, not
confusing with line wrap, to vi in gnome-terminal. Tried different
ways, from preview pane, from opened message in separate window, from
editor after hitting reply, tried the menu copy and paste, tried
selecting and middle mouse button... Yes, very annoying bug.
Comment 2 Bart Martens 2004-01-28 16:10:36 EST
Looks very much like this one:
http://bugzilla.ximian.com/show_bug.cgi?id=48907


Note You need to log in before you can comment on or make changes to this bug.