Bug 114391 - No 'ccm upgrade' command for run data model upgrades and Java upgrade code on an app
Summary: No 'ccm upgrade' command for run data model upgrades and Java upgrade code on...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: installation   
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Justin Ross
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 113496
TreeView+ depends on / blocked
 
Reported: 2004-01-27 16:15 UTC by Daniel Berrange
Modified: 2007-04-18 17:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 15:13:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2004-01-27 16:15:07 UTC
Description of problem:
As previously documented in the application packaging guide, upgrading
an application from one version to the next consists of running the
data model upgrade (cf data model load) scripts and then running a
java upgrade script (cd Loader scripts). For this a 'ccm upgrade'
command is needed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
NB, since we are effectively launching two pilot sites on RC0 in early
februrary this upgrade capability is going to be required RSN.

Comment 1 Richard Li 2004-02-16 16:31:25 UTC
Karsten: justin will be shipping you docs for this feature as soon as
he's done implementing it.

Comment 2 Richard Li 2004-02-16 16:51:10 UTC
also as part of this ticket we need to document how java code is
upgraded and convert scott's publishing upgrade initializer to follow
spec.

Comment 3 Richard Li 2004-02-17 19:59:39 UTC
This was done in 40431, 40435, 40443, and 40448.


Note You need to log in before you can comment on or make changes to this bug.