Bug 1143923 - vdsm depends on rsyslog
Summary: vdsm depends on rsyslog
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Yaniv Bronhaim
QA Contact: Gil Klein
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 09:25 UTC by Sven Kieske
Modified: 2016-02-10 19:32 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 14:18:21 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26941 None None None Never
oVirt gerrit 33089 ovirt-3.4 ABANDONED Remove rsyslog requirement and leave the check of syslog fd availability Never

Description Sven Kieske 2014-09-18 09:25:11 UTC
Description of problem:
This is a clone of BZ 1083100
as requested per Comment 13 for backporting this to 3.4.4

This is about this changeset:
http://gerrit.ovirt.org/26941

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Description of problem:

While performing a vdsm update manually on RHEL-Host,
rsyslog is the dependency any thing apart from this like "syslog-ng" 
cannot be used. 

# yum deplist vdsm > /tmp/dep

# grep rsyslog /tmp/dep
dependency: rsyslog
   provider: rsyslog.x86_64 4.6.2-2.el6
   provider: rsyslog.x86_64 4.6.2-3.el6
   provider: rsyslog.x86_64 4.6.2-3.el6_1.1
   provider: rsyslog.x86_64 4.6.2-3.el6_1.2
   provider: rsyslog.x86_64 4.6.2-3.el6_1.4
   provider: rsyslog.x86_64 4.6.2-12.el6
   provider: rsyslog.x86_64 5.8.10-2.el6
   provider: rsyslog.x86_64 5.8.10-6.el6
   provider: rsyslog.x86_64 5.8.10-7.el6_4
   provider: rsyslog.x86_64 5.8.10-8.el6
...

Version-Release number of selected component (if applicable): RHEV-3.3


How reproducible: always


Steps to Reproduce:
1. Put RHEL Hosts into maintenance mode and perform an update on it manually.
2. When syslog-ng is being used, rsyslog acts as an obstacle while updating vdsm.

Actual results: vdsm does not update.

Expected results: vdsm should not depend on rsyslog package to update.

Comment 1 Sandro Bonazzola 2014-09-24 08:11:28 UTC
Re-targeting since 3.4.4 has been released and only security/critical fixed will be allowed for 3.4.z. 3.5.0 is also in blockers only phase, so re-targeting to 3.5.1.

Comment 2 Sven Kieske 2014-09-24 09:42:43 UTC
Retargeting to 3.5.1 does not make sense as it is already fixed in 3.5:
https://bugzilla.redhat.com/show_bug.cgi?id=1083100
this was about backporting this patch to 3.4.4 which slipped the deadline somehow :(

Comment 3 Sandro Bonazzola 2014-09-30 06:45:52 UTC
(In reply to Sven Kieske from comment #2)
> Retargeting to 3.5.1 does not make sense as it is already fixed in 3.5:
> https://bugzilla.redhat.com/show_bug.cgi?id=1083100
> this was about backporting this patch to 3.4.4 which slipped the deadline
> somehow :(

Sorry, it was an automated message.
Yaniv, what do you want to do with this bug? Do you consider this important enough to require an async release? If not, please close next-release

Comment 4 Yaniv Bronhaim 2014-09-30 15:15:01 UTC
We are waiting for Scott's reply regarding this issue. Meanwhile I leave it open

Comment 5 Oved Ourfali 2014-09-30 18:07:25 UTC
Sandro - will we have another 3.4 build? 
If so, worth including... Wouldn't say it is highly important, but it is also harmless.

Comment 6 Sandro Bonazzola 2014-10-01 11:51:59 UTC
Oved: looks like VDSM is not yet stable as Dan would have liked and engine will gain hardware support with ppc patches. I think there's enough material for requesting an async release for vdsm and engine only. Please raise the issue in sync meeting.

Comment 7 Oved Ourfali 2014-10-01 14:18:21 UTC
Seems like there won't be another 3.4.Z release. So closing NEXTRELEASE as it will be fixed on 3.5.0 and above only.


Note You need to log in before you can comment on or make changes to this bug.