Bug 1143943 - glib2 segfaults in g_source_add_child_source() [NEEDINFO]
Summary: glib2 segfaults in g_source_add_child_source()
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glib2
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1104372
Blocks: 1143927
TreeView+ depends on / blocked
 
Reported: 2014-09-18 09:47 UTC by Stef Walter
Modified: 2015-05-06 14:24 UTC (History)
6 users (show)

Fixed In Version: glib2-2.40.0-4.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-06 14:24:04 UTC
ovasik: needinfo? (walters)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 701283 None None None Never

Description Stef Walter 2014-09-18 09:47:51 UTC
Description of problem:

glib2 segfaults in g_source_add_child_source() due to a bug in child source support. This bug is fixed upstream in glib2 2.37.4.

Version-Release number of selected component (if applicable):



How reproducible:

# Easily.

Steps to Reproduce:
1. Building and install cockpit on RHEL7.
2. systemctl start cockpit
3. Access cockpit with https on port 9090

Actual results:

cockpit-ws crashes

Expected results:

No crash

Comment 1 Stef Walter 2014-09-18 09:55:22 UTC
[root@rh7 ~]# rpm -q glib2
glib2-2.36.3-5.el7.x86_64
[root@rh7 ~]# rpm -q glib-networking
glib-networking-2.36.2-3.el7.x86_64

Example backtrace:

#0  g_main_context_remove_poll_unlocked (context=0x0, fd=0x6d2530) at gmain.c:4159
#1  0x00007ffff754d6e4 in block_source (source=0x6d24d0) at gmain.c:2947
#2  0x00007ffff754d738 in block_source (source=0x6d2420) at gmain.c:2959
#3  0x00007ffff754f560 in g_source_add_child_source (source=0x6d9aa0, child_source=0x6d2420) at gmain.c:1427
#4  0x00007ffff2a47f87 in gnutls_source_sync (gnutls_source=gnutls_source@entry=0x6d9aa0)
    at gtlsconnection-gnutls.c:881
#5  0x00007ffff2a48084 in gnutls_source_dispatch (source=source@entry=0x6d9aa0, callback=<optimized out>, 
    user_data=<optimized out>) at gtlsconnection-gnutls.c:895
#6  0x00007ffff7550ac6 in g_main_dispatch (context=0x6cd450) at gmain.c:3058
#7  g_main_context_dispatch (context=context@entry=0x6cd450) at gmain.c:3634
#8  0x00007ffff7550e48 in g_main_context_iterate (context=0x6cd450, block=block@entry=1, dispatch=dispatch@entry=1, 
    self=<optimized out>) at gmain.c:3705
#9  0x00007ffff755125a in g_main_loop_run (loop=0x655f60) at gmain.c:3899
#10 0x000000000040965d in main (argc=1, argv=0x7fffffffe4f8) at src/ws/main.c:168

Comment 5 Stef Walter 2014-09-18 13:26:05 UTC
Removing accidentally added private flag from bug.


Note You need to log in before you can comment on or make changes to this bug.