Bug 1143990 - Fedora Server is missing the adcli command on default install
Summary: Fedora Server is missing the adcli command on default install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard: RejectedBlocker
Depends On: 1143988
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 12:03 UTC by Stephen Gallagher
Modified: 2015-03-12 20:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-12 20:49:37 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Stephen Gallagher 2014-09-18 12:03:11 UTC
Description of problem:
The default installation of Fedora Server is meant to be possible to join an Active Directory domain. This requires the presence of the 'adcli' command on the system.

Version-Release number of selected component (if applicable):
Fedora Server 21 Alpha RC1

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora Server with all of the defaults.
2.
3.

Actual results:
adcli is not installed

Expected results:
adcli is installed

Additional info:
There is also BZ #1143988 where the automatic installation of this package is not working properly, so fixing this in comps will work around that issue as well.

Comment 1 Stephen Gallagher 2014-09-18 12:08:21 UTC
Fixed in comps by adding 'adcli' to the @domain-client group.

https://git.fedorahosted.org/cgit/comps.git/commit/?id=cb6f5701e8e838556e60639709b0dd965aa69938

Comment 2 Fedora Blocker Bugs Application 2014-09-18 12:14:37 UTC
Proposed as a Blocker for 21-alpha by Fedora user sgallagh using the blocker tracking app because:

 "It must be possible to join the system to a FreeIPA or Active Directory domain at install time and post-install, and the system must respect the identity, authentication and access control configuration provided by the domain."

Note 1: FreeIPA joins are working properly. It may be acceptable to accept that at least one of them works in Alpha and not block on this.

Note 2: A workaround exists for post-installation enrollment (manual install of the 'adcli' tool post-installation). No workaround exists for kickstart (violating the "at install time" statement) since the package is not currently included in the server install set.

Note 3: I've already pushed the fix to comps, so if an RC2 occurs, this is already set to be included.

Comment 3 Mike Ruckman 2014-09-18 19:52:49 UTC
Discussed in 2014-09-18 Go/No-Go meeting. Voted as a RejectedBlocker. While this bug seems to be a blocker, there are workarounds which make it possible to join AD domains. The fix will land in Beta TCs. The workarounds will be documented on Common Bugs.


Note You need to log in before you can comment on or make changes to this bug.