Bug 114401 - smp kernel panics early in boot
smp kernel panics early in boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 13:35 EST by Steven Pritchard
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 03:38:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Pritchard 2004-01-27 13:35:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The SMP kernel panics very early on while booting on a dual Opteron
240/Rioworks HDAMA system.  (I have no scrollback or serial console to
determine the point where the panic happens yet.)  The UP kernel boots
fine.

Also tested with identical results on 2.4.22-1.2163.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.22-1.2135

How reproducible:
Always

Steps to Reproduce:
1. On a fresh install of FC 0.96/x86_64, boot the SMP kernel.
Comment 1 Justin M. Forbes 2004-02-03 10:33:14 EST
At what point in the boot does this happen?  Any chance of getting a
serial console soon?
Comment 2 Sam Varshavchik 2004-02-04 07:10:12 EST
I hope to get to it soon.  I'm working on the box, trying to resolve
other showstoppers first.
Comment 3 Sam Varshavchik 2004-02-05 00:03:34 EST
The kernel panics right after initializing CPU 1 on this Dual Opteron.

The call trace in the panic includes some symbol information, without
the benefit of ksymoops.  The panic occurs in:  set_cpu_allowed+411.

The next entries in the call trace are:   free_uid+2, ksoftirq+77,
child_rip+8, ksoftirq+0, child_rip+0

Code: 8b 4b 3c 48 69 c9 ...

Still working on a serial console, to capture the whole thing,
hopefully the above may be helpful in the meantime.
Comment 4 Sam Varshavchik 2004-02-05 21:48:17 EST
I have the serial console attached; however it looks like the SMP
kernel does not panic consistently.  I've been able to boot the SMP
kernel a couple of times already, with the serial console attached.

I will keep the serial console available, and update this bug when I
capture a panic.
Comment 5 Sam Varshavchik 2004-02-10 21:46:44 EST
After some additional testing I cannot reproduce the bug after
updating to kernel build 2.4.22-1.2166.nptlsmp and flashing the
motherboard to the latest OEM BIOS.

There does appear to be a residual problem with the aic79xx.o module
(I can crash it fairly reliably), but that's going to be a different bug.
Comment 6 Sahil Verma 2004-03-22 02:14:38 EST
This bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.