Bug 1144050 - Staypuft doesn't create & set a type for each Cinder back end when configuring multiple back ends
Summary: Staypuft doesn't create & set a type for each Cinder back end when configurin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: All
OS: All
urgent
high
Target Milestone: z2
: Installer
Assignee: Jiri Stransky
QA Contact: Yogev Rabl
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 14:17 UTC by Yogev Rabl
Modified: 2014-11-04 17:02 UTC (History)
7 users (show)

Fixed In Version: openstack-foreman-installer-2.0.29-1.el6ost
Doc Type: Enhancement
Doc Text:
When configuring Block Storage with multiple storage backends, users can now use volume types to specify which backend should be used when creating a volume. To use volume types, the create_volume_types parameter must set to 'true'.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:02:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Yogev Rabl 2014-09-18 14:17:14 UTC
Description of problem:
The configuration of multiple back ends in Cinder requires to create for each back end a type and relate each type to a back end, as the manual show here: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/3/html/Installation_and_Configuration_Guide/Configuring_for_Multiple_Storage_Backends.html

When deploying Cinder with two back ends: Ceph & LVM there were no type after the installation.

Version-Release number of selected component (if applicable):
ruby193-rubygem-staypuft-0.3.5-1.el6ost.noarch

How reproducible:

Steps to Reproduce:
1. Set the Cinder back ends to 1< back ends. 
2. Deploy OSP with staypuft


Actual results:
There are no types in cinder.

Expected results:
There is a type for each back end and each type is related to one back end.


Additional info:

Comment 3 Jiri Stransky 2014-10-06 14:45:46 UTC
Pull request upstream with description how i tested:

https://github.com/redhat-openstack/astapor/pull/382

Comment 4 Jason Guiditta 2014-10-09 18:52:04 UTC
Merged

Comment 7 Yogev Rabl 2014-10-26 10:25:10 UTC
verfied in version:
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch

Comment 9 errata-xmlrpc 2014-11-04 17:02:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.