Bug 1144052 - On group creation error, info messages are under fadeout window
Summary: On group creation error, info messages are under fadeout window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER05
: JON 3.3.0
Assignee: Jirka Kremser
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 14:18 UTC by Jeeva Kandasamy
Modified: 2014-12-11 14:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:01:15 UTC
Type: Bug


Attachments (Terms of Use)
error info messages under fadeout window (97.91 KB, application/octet-stream)
2014-09-18 14:18 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-09-18 14:18:11 UTC
Created attachment 938922 [details]
error info messages under fadeout window

Description of problem:
On group creation, if the group is already exists we are getting an error message and if is is available to create, shows available indication icon, which is under fadout window and unable to notice easily.

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.ER03
Build Number : 4aefe39:44e33a4
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 32.0

How reproducible:
always

Steps to Reproduce:
1. Create new group, Click on 'New' under 'Inventory->Groups->All Groups'
2. Enter a group which is already available.

Additional info: Screen shot is attached.

Comment 1 Jirka Kremser 2014-09-29 15:33:25 UTC
Based on this article [1] it is not possible to use only z-index for taking some component into foreground if the two components are in different stacking contexts. This is our case in this bz. So the only solution to this problem is not to create stacking context for the notification messages (by setting the z-index to auto to all its parents)

After quite some time I came with this css snipet that hot-fixes this issue:

body > div > div[eventproxy="isc_HTMLFlow_0"],
body > div.normal {
    z-index: auto !important;
}

It is, however, far from perfect because it can match to any <div> directly under <body>.

[1]: http://philipwalton.com/articles/what-no-one-told-you-about-z-index/

Comment 2 Jirka Kremser 2014-09-30 19:08:58 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/5ef0baba7
time:    2014-09-30 21:08:05 +0200
commit:  5ef0baba7378e0f805f2362bdc6c4c4d9cbce7b3
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1144052] - On group creation error, info messages are under fadeout
         window - the z-index css attribute was ignored, because there
         were two different so called stacking contexts. By setting the
         z-index to the default value (which is auto) to all related
         parent elements we prevent creating new stacking contexts. In
         other words z-index works correctly only for leave elements in
         the DOM tree, but if we combine different z-indices in one
         sub-tree it causes strange behavior.

Comment 3 Jirka Kremser 2014-10-02 12:50:01 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/c0ea3f24b
time:    2014-10-02 14:49:22 +0200
commit:  c0ea3f24b62dd3b82367e3a42f18ac6da2206d48
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1144052] - Setting z-index to auto to all parents of the logout
         dropdown menu to join its DOM subtree to the global stacking
         context and make the z-index working again for it. Result is
         that it will be on the top even if there is a notification.
         Also hiding the ajax loader gif icon, because it is not needed
         anymore.

Comment 4 Libor Zoubek 2014-10-02 13:57:27 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/d9bdee59e
time:    2014-10-02 15:56:45 +0200
commit:  d9bdee59e13c172ebd73b5b38ef750593f50de06
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1144052] - On group creation error, info messages are under fadeout
         window - the z-index css attribute was ignored, because there
         were two different so called stacking contexts. By setting the
         z-index to the default value (which is auto) to all related
         parent elements we prevent creating new stacking contexts. In
         other words z-index works correctly only for leave elements in
         the DOM tree, but if we combine different z-indices in one
         sub-tree it causes strange behavior.

         (cherry picked from commit
         5ef0baba7378e0f805f2362bdc6c4c4d9cbce7b3) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>
         

branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/7bde4e4cb
time:    2014-10-02 15:56:28 +0200
commit:  7bde4e4cb9e5db6221e2056d7c7746060d36960c
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1144052] - Setting z-index to auto to all parents of the logout
         dropdown menu to join its DOM subtree to the global stacking
         context and make the z-index working again for it. Result is
         that it will be on the top even if there is a notification.
         Also hiding the ajax loader gif icon, because it is not needed
         anymore.

         (cherry picked from commit
         c0ea3f24b62dd3b82367e3a42f18ac6da2206d48) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>

         Conflicts:
         modules/enterprise/gui/coregui/src/main/webapp/org.rhq.coregui.CoreGUI/sc/skins/CoreGUI/skin_styles.css

Comment 5 Simeon Pinder 2014-10-21 20:24:41 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 6 Sunil Kondkar 2014-10-28 10:06:17 UTC
Verified on Version:3.3.0.ER05  Build Number :92b6d6a:2cdb528

while creating a new group, the messages for existing and available group are visible now.


Note You need to log in before you can comment on or make changes to this bug.