Bug 1144146 - Messaging queue and subscriber runtime is not exposed
Summary: Messaging queue and subscriber runtime is not exposed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.2.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER05
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 19:06 UTC by Larry O'Leary
Modified: 2018-12-06 18:02 UTC (History)
7 users (show)

(edit)
The agent plug-in component did not support monitoring runtime queues and topic subscribers on the HornetQ resource. New resource types for runtime-queue are introduced, supporting all operations and monitoring all metrics exposed by EAP. Because runtime queues can frequently appear and disappear, the Missing Resource Policy now makes it possible to auto-uninventory non-existant runtime-queues as required. These fixes now allow users to monitor and manage topic subscribers and runtime queues more efficiently.
Clone Of:
(edit)
Last Closed: 2014-12-11 14:03:23 UTC


Attachments (Terms of Use)
JMS queue appeared (103.26 KB, image/png)
2014-10-30 11:28 UTC, Garik Khachikyan
no flags Details

Description Larry O'Leary 2014-09-18 19:06:08 UTC
Description of problem:
The JBoss EAP 6 management plug-in fails to discover and expose the runtime resources found under runtime-queues. This means that runtime queues and topic subscribers can not be monitored using the management plug-in.

For example:

Queue:
/subsystem=messaging/hornetq-server=default/runtime-queue=jms.queue.HELLOWORLDMDBQueue:read-resource(recursive=true,include-defaults=true,include-runtime=true)

Topic and one of its subscribers:
/subsystem=messaging/hornetq-server=default/runtime-queue=jms.topic.HELLOWORLDMDBTopic:read-resource(recursive=true,include-defaults=true,include-runtime=true)
/subsystem=messaging/hornetq-server=default/runtime-queue=3e541b64-097d-416e-b867-97855a2db54a:read-resource(recursive=true,include-defaults=true,include-runtime=true)

Version-Release number of selected component (if applicable):
JBoss EAP 6 management plug-in for JBoss ON 3.2

How reproducible:
Always

Steps to Reproduce:
1. Deploy the jboss-eap-quickstarts/helloworld-jms quickstart message queue and topics.
2. Force discovery
3. Notice no topic subscribers/queues are discovered

Comment 1 Jay Shaughnessy 2014-09-19 20:33:19 UTC
I guess this is asking for new resource types.  Target for ER05.

Comment 3 Libor Zoubek 2014-10-02 13:51:37 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/1b5f73629
time:    2014-10-02 15:51:00 +0200
commit:  1b5f736296dbcebac399b57c61bca0b0ab7fd984
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1144146 - Messaging queue and subscriber runtime is not exposed

         Added 2 new resource types to AS7 plugin (for Standalone and
         Managed server) with supportsMissingAvailabilityType="true",
         because runtime-queues and topic subscribers will likely appear
         and disappear.

         BaseComponent#getAvailability() was fixed to support 
         supportsMissingAvailabilityType=true whenever it is defined in
         resource type.

Comment 4 Thomas Segismont 2014-10-09 16:10:43 UTC
Cherry-picked over to release/jon3.3.x

commit aa1e5c3ed423926aba73bbdeea4f9976eb98e358
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Thu Oct 2 15:48:42 2014 +0200
    
    Added 2 new resource types to AS7 plugin (for Standalone and Managed server)
    with supportsMissingAvailabilityType="true", because runtime-queues and
    topic subscribers will likely appear and disappear.
    
    BaseComponent#getAvailability() was fixed to support
    supportsMissingAvailabilityType=true whenever it is defined in resource
    type.
    
    (cherry picked from commit 1b5f736296dbcebac399b57c61bca0b0ab7fd984)
    Signed-off-by: Thomas Segismont <tsegismo@redhat.com>

Comment 6 Simeon Pinder 2014-10-21 20:24:32 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 9 Garik Khachikyan 2014-10-30 11:28:10 UTC
Created attachment 952067 [details]
JMS queue appeared

# SCENARIO 1

jms queue appeared (in case of Linux EAP6 Standalone server)

scenario performed:

1. plug an agent with EAP6 linux standalone server
2. follow steps: http://www.jboss.org/quickstarts/eap/helloworld-jms/ (create the user, connect with config file specified in there)
3. manual discovery
4. visit the Agent -> JBossAS7 Standalone Servers -> Subsystems -> messaging -> HornetQs -> default -> JMS Queues -> testQueue (it's there!)

Comment 10 Garik Khachikyan 2014-10-30 12:39:40 UTC
# VERIFIED

putting the bug to verified (was not able to process for Windows case got exception(s) saying):
---
c:\jboss-eap-6.3\bin>jboss-cli.bat --controller=localhost:10099 --connect  --fil
e=C:\Users\Administrator\Downloads\jboss-eap-quickstarts-6.3.0.GA\helloworld-jms
\configure-jms.cli
Failed to add to batch 'jms-queue add --queue-address=testQueue --entries=queue/
test,java:jboss/exported/jms/queue/test': Command is not supported or unavailabl
e in the current context: JBAS014883: No resource definition is registered for a
ddress [
    ("subsystem" => "messaging"),
    ("hornetq-server" => "default"),
    ("jms-queue" => "?")
]
Press any key to continue . . .

Comment 14 Garik Khachikyan 2014-10-30 15:30:08 UTC
BTW: good news: Windows case looks fine - working :)


Note You need to log in before you can comment on or make changes to this bug.