Bug 1144162 - Cannot use UTF8 characters as a user's login, firstname or lastname
Summary: Cannot use UTF8 characters as a user's login, firstname or lastname
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Bruno Rocha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 19:51 UTC by jaudet
Modified: 2019-09-25 20:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:45:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
Server log for the described error. (2.77 KB, text/plain)
2014-09-18 19:52 UTC, jaudet
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7548 Normal Closed Cannot use UTF8 characters as a user's login, firstname or lastname 2020-04-15 16:15:24 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description jaudet 2014-09-18 19:51:47 UTC
Description of problem:
The server returns an HTTP 422 response when creating a user if UTF-8 characters are provided for that user's login, firstname or lastname. Note that other types of interesting characters are allowed, such as latin-1 and CJK.

Version-Release number of selected component (if applicable):
The following software is installed:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.46-1.el6sat.noarch
* foreman-compute-1.6.0.46-1.el6sat.noarch
* foreman-gce-1.6.0.46-1.el6sat.noarch
* foreman-libvirt-1.6.0.46-1.el6sat.noarch
* foreman-ovirt-1.6.0.46-1.el6sat.noarch
* foreman-postgresql-1.6.0.46-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.46-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-0.0.64-1.el6sat.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.7.beta.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.7.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.7.beta.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.7.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.7.beta.el6sat.noarch
* pulp-selinux-2.4.1-0.7.beta.el6sat.noarch
* pulp-server-2.4.1-0.7.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
_Almost_ always.

Steps to Reproduce:
1. Create a user via the API. Provide any number of UTF-8 characters as a login, firstname or lastname.

Actual results:
HTTP 422 response with one of the following messages:

* First name is invalid
* Last name is invalid
* Surname is invalid

Expected results:
One of the following:

* A user is created.
* A helpful error message is returned.

Additional info:
Once in a while - say, once every 20 attempts - a user is sucessfully created even though UTF-8 chars are submitted.

Comment 1 jaudet 2014-09-18 19:52:34 UTC
Created attachment 939027 [details]
Server log for the described error.

Comment 2 jaudet 2014-09-18 20:02:14 UTC
A test targeting this issue has been created. See: https://github.com/SatelliteQE/robottelo/pull/1403

Comment 3 RHEL Program Management 2014-09-18 20:03:13 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Dominic Cleal 2014-09-19 15:43:28 UTC
Created redmine issue http://projects.theforeman.org/issues/7548 from this bug

Comment 7 Bryan Kearney 2015-12-03 17:04:35 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7548 has been closed
-------------
Anonymous
Applied in changeset commit:f4aa6463dc217aa2739927997a51254988ad929f.

Comment 8 Bryan Kearney 2015-12-09 13:40:03 UTC
moving fixed intems into 6.2

Comment 11 Og Maciel 2016-03-22 19:56:39 UTC
The following permutations were used to verify this issue:

Login | First Name | Surname
-----------------------------
überüser | Bart Simpson
mane | Zé | Mane
rolo | Ze | Mané
㳤沪㛴懎镶歿宓퓺헍艁 | 㳤沪㛴懎镶歿 | 宓퓺헍艁

* All users were successfully created via the web UI
* All users were able to successfully log in via the web UI

Next step, we will check this issue using the REST API.

Comment 12 Bruno Rocha 2016-03-22 20:52:33 UTC
API 

Verified on: Satellite6.2.0 Snap4.0 running on RHEL 7 x86_64

Steps:

* Use curl to call the /api/users API endpoint
* Create a user for each variant on table (see below)
* Login via the web UI using each user

curl -X POST -H "Content-Type: application/json" -H "Authorization: Basic KEY" -d '{
    "user": {
        "login": "USER",
        "firstname": "FIRST",
        "lastname": "LAST",
        "mail": "bart@simpson.com",
        "password": "s3cr3tâé",
        "auth_source_id": 1
    }
}' "https://SATELLITE_HOST/api/users"


The above was tested for each variant below:

Login | First Name | Surname
-----------------------------
überüser | Bart Simpson
mane | Zé | Mane
rolo | Ze | Mané
㳤沪㛴懎镶歿宓퓺헍艁 | 㳤沪㛴懎镶歿 | 宓퓺헍艁


Result:

* All users were successfully created via the REST API (curl & postman)
* All users were able to successfully log in via the web UI

Comment 15 errata-xmlrpc 2016-07-27 08:45:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.