Bug 114443 - /proc/acpi/event is root-only
/proc/acpi/event is root-only
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 02:51 EST by Bill Nottingham
Modified: 2015-01-04 17:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 23:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-01-28 02:51:24 EST
Description of problem:

/proc/acpi/event is root-only for read

Version-Release number of selected component (if applicable):

2.6.1-1.57

How reproducible:

Every time!

Steps to Reproduce:
1. $ cat /proc/acpi/event
2. -EPERM
3. there is no step 3.
  
Actual results:

-EPERM

Expected results:

Glorious ACPI events.

The lack of readibility makes writing battery monitors ... tricky.

Additional info:

Hey, at least chmod() on it works!
Comment 1 Dave Jones 2004-10-29 23:57:39 EDT
not any more it doesn't 8-)
is this actually a problem?  Battery monitors seem to work fine for me.
Comment 2 Bill Nottingham 2004-10-30 00:50:34 EDT
Is acpid running when your battery monitor is working?
Comment 3 Dave Jones 2004-11-01 14:19:19 EST
yes, why is that a problem ?
Comment 4 Bill Nottingham 2004-11-01 14:48:50 EST
Does the battery monitor work once you turn off acpid?
Comment 5 Dave Jones 2004-11-02 15:40:42 EST
no, as the battery applet talks to the acpid socket.
This isn't supposed to work afaict.

I don't see what we benefit by making /proc/acpi/event world readable, other
than a bunch of headaches. (Note that it can only have one exclusive reader by
design)
Comment 6 Bill Nottingham 2004-11-02 22:57:22 EST
Well, the battery applet has code to work without acpid... as long as
it's readable.

I suppose it's simpler to just get all the acpi notification on the
kernel events layer, or similar.
Comment 7 Dave Jones 2004-11-22 15:06:03 EST
"the battery applet has code to work without acpid"

Why ?
Comment 8 Bill Nottingham 2004-11-22 15:58:59 EST
Probably because acpid is crap. Not sure, though. :)
Comment 9 Dave Jones 2005-01-10 23:56:04 EST
I don't think there's a compelling argument to keep this one open.

Note You need to log in before you can comment on or make changes to this bug.