Bug 114444 - Can't do a CVS checkout to a Samba share (mapped at Windows)
Summary: Can't do a CVS checkout to a Samba share (mapped at Windows)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: samba   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-28 10:18 UTC by Robert Scheck
Modified: 2014-08-31 23:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-15 17:48:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-01-28 10:18:16 UTC
Description of problem, how reproducible & steps to reproduce:
I mapped a Samba share at my Windows computer to a drive. Then I
tried to checkout a CVS module with WinCVS or TortoiseCVS to the 
mapped network drive.

The Samba server was one time Fedora Core 1 and another time Fedora 
Rawhide - so in both times Samba version >= 3.0.0.

But the CVS checkout didn't work - it simply died with: 

--- snipp ---
cvs [checkout aborted]: cannot make directory <cvs-module>: No such file or directory
--- snapp ---

I searched around Google and diverse mailing lists - no 
results...some people seems to have the same problem, but still no
result or solution.

The only match I found a few minutes ago:
http://lists.samba.org/archive/samba-technical/2003-October/032321.html

So I tried a downgrade to the Samba version of Red Hat Linux 9.
Now, all works fine - the problem IS Samba 3.x.x :-(

Version-Release number of selected component (if applicable):
>= samba-3.0.0 (ALL 3.x.x!)

Actual results:
The problem seems to be a bug introduced with Samba 3.0.0beta2 (!!),
as Andreas wrote it at the mailing list (see link above).

Expected results:
Fix that annoying bug immediately, please! Thank you very much :-)

Additional info:
The CVS server, where the checkout was done from cvs-1.11.5-3
(Fedora Core 1 CVS).

Comment 1 Robert Scheck 2004-01-28 10:35:06 UTC
Oh sorry, I forgot the Windows versions, I used for that tests and
where the problem was reproducible:

Windows 9x, NT, 2000 and XP (always with the latest available updates)

Comment 2 Gerald Carter 2004-01-28 17:25:07 UTC
This is fixed in 3.0.1 according to duplicate bugs reports
on the samba ml.

Comment 3 Jay Fenlason 2004-02-24 22:12:11 UTC
Can you please try the 3.0.2a-1 RPMS from Raw Hide and confirm whether
or not they fix the problem?

Comment 4 Robert Scheck 2004-03-15 17:48:10 UTC
The latest Samba RPM from Fedora Development seems to work :-)


Note You need to log in before you can comment on or make changes to this bug.