Bug 1144520 - autopart is always pre-selected upon entry to the storage spoke
Summary: autopart is always pre-selected upon entry to the storage spoke
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-19 16:08 UTC by David Lehman
Modified: 2014-10-11 06:53 UTC (History)
7 users (show)

Fixed In Version: anaconda-21.48.8-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1144603 (view as bug list)
Environment:
Last Closed: 2014-10-11 06:53:53 UTC
Type: Bug


Attachments (Terms of Use)

Description David Lehman 2014-09-19 16:08:04 UTC
Description of problem:
Regardless of whether you provided a ks.cfg containing custom storage or previously visited the custom spoke in the GUI, the initial selection is always "Automatic partitioning" or similar.

Version-Release number of selected component (if applicable):
anaconda-21.48.6-1

How reproducible:
Always

Steps to Reproduce:
1. either specify a ks w/ custom storage or visit the custom spoke
2. revisit the storage spoke
3. note the setting of autopart -v- custom

Actual results:
It's always autopart.

Expected results:
It should be whatever was previously specified.

Additional info:

Comment 1 David Lehman 2014-09-19 18:54:02 UTC
Already fixed on master.

Comment 2 Kamil Páral 2014-09-24 18:20:49 UTC
Discussed in 2014-09-24 Blocker Review meeting [1]. Rejected as a blocker. This bug is an oddity that doesn't actually violate a criteria but still works as intended if you don't enter the spoke. That doesn't mean it can't get committed, however. We're not yet in a freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-09-24/

Comment 3 Fedora Update System 2014-10-01 15:36:04 UTC
anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21

Comment 4 Fedora Update System 2014-10-03 04:00:09 UTC
Package anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.8-1.fc21 python-blivet-0.61.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11977/python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-10-04 03:22:40 UTC
Package anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21, pykickstart-1.99.60-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.8-1.fc21 python-blivet-0.61.3-1.fc21 pykickstart-1.99.60-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11977/pykickstart-1.99.60-2.fc21,python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-10-11 06:53:53 UTC
anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21, pykickstart-1.99.60-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.