Bug 114455 - Error recompiling standard PHP source rpm with rpmbuild
Error recompiling standard PHP source rpm with rpmbuild
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 07:30 EST by Alvaro Palma
Modified: 2007-04-18 13:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 08:20:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alvaro Palma 2004-01-28 07:30:26 EST
Description of problem:

I'm trying to recompile latest source rpm for php in my own machine, 
using:

rpmbuild --rebuild --target=i386 php-4.1.2-7.2.6.src.rpm

But it always ends up with an error during configure part:

checking for CRYPTO_free in -lcrypto... no
configure: error: libcrypto not found!

All the dependences are installed.

Version-Release number of selected component (if applicable):

php-4.1.2-7.2.6.src.rpm

How reproducible:

Recompile PHP for the source rpm in your own machine

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I started this problem trying to rebuild php, adding support for 
Oracle8i, using 

rpmbuild --rebuild --target=i386 --define 'oracle 1' php-4.1.2-
7.2.6.src.rpm

having previously installed Oracle client, and setted up all Oracle 
environment variables, of course. Since it also fails, I thought it 
could be caused by Oracle, so I tried standard recompilation, but, as 
I showed, it failed too.
Comment 1 Joe Orton 2004-02-03 07:56:45 EST
checking for CRYPTO_free in -lcrypto... no

means you probably don't have openssl-devel installed.  Regardless,
RHL7.2 is no longer supported.
Comment 2 Alvaro Palma 2004-02-03 08:18:28 EST
I have openssl-devel and all dependences correctly installed, 
besides, if they wouldn't be installed, the rpmbuild would return an 
error. I report the bug because I guess this bug also exists in 
RedHat 9 (unfortunately I don't have a RH 9 box to test). Anyway, 
sorry for report the bug in an unsupported platform.
Comment 3 Joe Orton 2004-02-03 08:20:38 EST
Please reopen and attach the config.log produced if you can reproduce
this against a supported release.

Note You need to log in before you can comment on or make changes to this bug.