Bug 114459 - mode_switch key ignored
mode_switch key ignored
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 08:23 EST by Wolfgang Arendt
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 11:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Arendt 2004-01-28 08:23:44 EST
Description of problem:
Failure trying to enter tne @-character (which is Alt-GR + q on my
german keyboard).

My configuration:
I use Exceed Version 9 on Windows XP as X server from a remote
machine. My Keyboard in Exceed is configured to german.xkb. Changing
of keyboard layout is allowed in Exceed. In Control Center my keyboard
is configured to de-latin1 w/o deadkeys. I am able to enter the @
character in an xterm and other X applications but not in gtk2 (?)
applications, especially in the Red Hat configuration utility for apache.
I have installed the 'server' selection of Red Hat 9 and I have chosen
to 'install everything' later on. My hardware is a Compaq Proliant DL380.

Changing my keyboard layout with 
  xmodmap -e 'keycode  19 = ssharp question backslash t'
(note the 't', which is _not_ standard on german keyboards) enables me
to enter the @ sign (apparently enabling my Alt-GR key). It remains
this way, even when switching back to normal german keyboard layout with
  xmodmap -e 'keycode  19 = ssharp question backslash'
I tried with 'xev', whether X ignores, that I press the Alt-GR key
(keycode 97, Mode_switch), but obviously it does.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. set Display variable and start redhat-config-httpd
2. try to enter an @, \ or | character and fail
3. run xmodmap -e 'keycode 19 = ssharp question backslash t' &&
  xmodmap -e 'keycode 19 = ssharp question backslash'
  
Actual results:
Before step 3 it is not possible to enter characters @, \ and |.
After step 3 it is.

Expected results:
The same behaviour without running the xmodmap commands.

Additional info:
There is no keycode definition with four meanings of a single keycode
in the german keyboard definition.
Comment 1 Wolfgang Arendt 2004-01-28 18:59:39 EST
My statement about trying with xev is ambiguous. It should read:
I tried, whether X ignores a depressed Alt-GR key, but it does not
ignore it.
Comment 2 Phil Knirsch 2004-07-30 11:52:48 EDT
Hm, but that sounds more of a underlying problem, the
redhat-config-httpd application can't do anything about keyboard input.

I'm reassigning this bug to gtk, maybe it's a know problem there.

Read ya, Phil
Comment 3 Matthias Clasen 2004-09-08 15:45:03 EDT
I think this is the same problem as 
http://bugzilla.gnome.org/show_bug.cgi?id=144808
Comment 4 Matthias Clasen 2004-09-20 11:37:25 EDT
I assume that this is fixed with gtk2-2.2.4-8.1 in RHEL3, but I have a
hard time testing it, since I don't have access to an Exceed X server...

Note You need to log in before you can comment on or make changes to this bug.