Bug 114461 - named-checkconf silent: log category referencing not existing channel
named-checkconf silent: log category referencing not existing channel
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 08:47 EST by Ales Ledvinka
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 10:41:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Ledvinka 2004-01-28 08:47:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
named.conf with
logging {
        category "default" {
                "vse"; "syslog";
        };
        channel "syslog" {
                syslog daemon;
                severity dynamic;
        };
};

prevents named startup.
Jan 28 13:19:44 www named[15451]: logging channel 'vse': not found
Jan 28 13:19:44 www named[15451]: configuring logging: not found
Jan 28 13:19:44 www named[15451]: loading configuration: not found
Jan 28 13:19:44 www named[15451]: exiting (due to fatal error)

named-checkconf remains silent about this misconfiguration.

Version-Release number of selected component (if applicable):
bind-9.2.1-16

How reproducible:
Always

Steps to Reproduce:
1.up2date -i bind
2.add logging in named.conf as shown in description
3.named-checkconf
4.service named start
    

Additional info:
Comment 1 Jason Vas Dias 2004-08-25 10:41:11 EDT
 Yes - the current named-checkconf won't complain about errors in 
 zone files or views either.
 The new bind-9.3.0, to which we will be migrating shortly, does
 return non-zero for zone file or view errors - but still not logs.
 This is because only the actual server code goes so far as to attempt
 to USE the logging configuration, when these errors are found .
 This issue has been reported to the upstream maintainers where it 
 would be more appropriately fixed. 
 Once the new bind-9.3.0 named-checkconf is released, which is 
 radically different from the curent named-checkconf, we can
 revisit this issue. 

Note You need to log in before you can comment on or make changes to this bug.