Bug 1144623 - RFE: skip user creation on intial setup & gnome intial setup
Summary: RFE: skip user creation on intial setup & gnome intial setup
Keywords:
Status: CLOSED DUPLICATE of bug 1226819
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-initial-setup
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rui Matos
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-19 22:46 UTC by Dimitri Maziuk
Modified: 2017-03-13 13:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 13:26:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dimitri Maziuk 2014-09-19 22:46:44 UTC
Description of problem:

Note: I'm deploying/reimaging maybe 3 workstations/year, creating kickstart files will likely take longer than just installing 'em.

Here's what I do on centos 6:
- during initial setup on user creation screen click on "use network login" - "OK" to fool the installer into enabling the "continue" button,
- login as root -- either locally or ssh from another machine, then
1. install pam_ldap and nss-pam-ldapd,
2. edit /etc/sysconfig/authconfig and set FORCELEGACY=yes,
3. edit automounter maps and restart autofs to mount /home,
then I can run authconfig and set up my ldap auth.

So if you can fit this (also NIS+ and whatever else people out there might be using) into firstboot/initial-setup/gnome-initial-setup, that's fine with me. Otherwise 

please add the "I will configure user accounts later" button to the user creation screen so I can get past it.

(With "yes I really know what I'm doing" check box if you need to.)

Comment 2 Martin Kolman 2014-12-15 17:51:31 UTC
(In reply to Dimitri Maziuk from comment #0)
> please add the "I will configure user accounts later" button to the user
> creation screen so I can get past it.
> 
> (With "yes I really know what I'm doing" check box if you need to.)
Well, Initial Setup does not force you to create a user account. Once you accept the EULA, you can click the FINISH CONFIGURATION button right away, without creating a new user. Or did you mean something else ?

Comment 3 Dimitri Maziuk 2014-12-15 18:07:09 UTC
I really don't care which component is responsible, it looks like there's 3: install, initial setup, and gnome first run -- I just want to be able to install it and fire it up without making a non-root user.

At the moment it won't let me. Can you install a centos7/rh7 giu workstation without making a non-root user?

Comment 4 Martin Kolman 2014-12-17 14:02:03 UTC
(In reply to Dimitri Maziuk from comment #3)
> I really don't care which component is responsible, it looks like there's 3:
> install, initial setup, and gnome first run -- I just want to be able to
> install it and fire it up without making a non-root user.
It is definitely not a problem in Initial Setup - Initial Setup lets you proceed without creating a user.

Comment 5 Martin Kolman 2014-12-17 14:05:37 UTC
> At the moment it won't let me. Can you install a centos7/rh7 giu workstation
> without making a non-root user?

    While Red Hat welcomes bug reports on Red Hat products here in our
    public bugzilla database, please keep in mind that bugzilla is not a
    support tool or means of accessing support.  If you would like
    technical support please visit our support portal at access.redhat.com
    or call us for information on subscription offerings to suit your
    needs.

Comment 6 Dimitri Maziuk 2014-12-17 16:12:05 UTC
Please take a look at https://bugzilla.redhat.com/show_bug.cgi?id=965797 esp. comment 20. As of mid-September using kickstart without *both* initial-setup and gnome-initial-setup is still the only way to install a rh7 gui workstation without creating a local user.

Comment 7 Dimitri Maziuk 2015-05-02 15:34:33 UTC
OK, centos build 7.1 let me past initial setup without creating a user, but gnome still persists.

My users are in LDAP.

My /home is NFS-mounted. Gnome creating a homedir there messes up the automounter later.

Local user creation makes sense on ubuntu where root is disabled from the start and you cannot login and configure your auth without another account. If root is not disabled it serves no purpose. An enterprise will most likely have a single sign-on so in an enterprise distribution this is annoying at best.

Comment 8 Matthias Clasen 2015-05-28 23:01:57 UTC
gnome-initial-setup lets you set up ldap accounts, by using the 'Enterprise Login' button.

If you want to skip gnome-initial-setup entirely, you can do so, by putting

InitialSetupEnable=false

into the [daemon] section of /etc/gdm/custom.conf

You will still get gnome-initial-setup running inside the user session the first time you log in. To prevent that, you can create a file named ~/.config/gnome-initial-setup-done in the users home directory.

Comment 9 Dimitri Maziuk 2015-05-28 23:23:57 UTC
(In reply to Matthias Clasen from comment #8)

Creating a user makes perfect sense on mac'oh-buntu where root account is disabled out of the box. On RHEL it isn't, all I need is login as root. The problem is *I don't get to login* until after I've created a local user account.

For myself I only need to get past this so I can install epel & xfce, to make it all particularly annoying. ;)

Comment 10 Dimitri Maziuk 2015-06-03 21:14:15 UTC
After setting up another pc:

there is another simple way around this: just select "kde plasma workspaces" instead of a gui workstation install. No gnome, no gnome-initial-setup, can login, install gnome and edit its config files as per #c8

Comment 11 Konstantin Olchanski 2015-08-04 21:09:03 UTC
(In reply to Matthias Clasen from comment #8)
> gnome-initial-setup lets you set up ldap accounts ...

For the record, we use NIS, not LDAP.

No way to install 7.1 without creating (and later deleting) a fake local user.

Makes no sense to have a "Enterprise" product reject a common enterprise configuration
and default to something more suitable for personal laptop or home PC.

K.O.

Comment 12 Dimitri Maziuk 2015-08-04 22:16:06 UTC
Install "kde workspaces" instead, then group-install gnome after setting up authconfig etc. Although I have to say, I ran into enough little things that are not working or simply missing compared to 6.x by now that I'm not upgrading any more workstations.

Comment 13 Konstantin Olchanski 2015-08-07 22:39:17 UTC
(In reply to Dimitri Maziuk from comment #12)
> Install "kde workspaces" instead ...

this does not help with the initial installation of 7.1 using stock installer - the only options I am offered is - LDAP or create (then delete) a fake local user.

acceptable solution would be - restore support for NIS or make mandatory creation of local user optional.

K.O.

Comment 14 Dimitri Maziuk 2015-08-08 16:24:46 UTC
(In reply to Konstantin Olchanski from comment #13)
> (In reply to Dimitri Maziuk from comment #12)
> > Install "kde workspaces" instead ...
> 
> this does not help with the initial installation of 7.1 using stock
> installer - the only options I am offered is - LDAP or create (then delete)
> a fake local user.

Interesting... I was able to get past initial setup without creating a user in centos 7.1. 7.0 initial install insisted on the local user, in 7.1 it's only gnome that wanted a local user. I used the "everything" or whatever it's called installer off a usb stick.

Comment 15 Dimitri Maziuk 2015-08-20 21:45:58 UTC
OK, I lied. You have to edit gdm/custom.conf as per #8 after group-installing gnome. Still, my recipe gets you to the point where you can actually do it.

Comment 16 Rui Matos 2017-03-13 13:26:09 UTC

*** This bug has been marked as a duplicate of bug 1226819 ***


Note You need to log in before you can comment on or make changes to this bug.