Bug 114474 - xmlrpc queries no longer seem to work
Summary: xmlrpc queries no longer seem to work
Status: CLOSED WORKSFORME
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.17
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: http://people.redhat.com/jrb/files/bu...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-28 15:39 UTC by Paul Nasrat
Modified: 2007-04-18 17:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 11:48:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Nasrat 2004-01-28 15:39:42 UTC
Description of problem:

Upon running a bugtool or bugzuki query I get an xmlrpc error

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Download bugtool
2. Install
3. run bugtool from a terminal
4. Select one of the queries

Actual results:

xmlrpclib.Fault: <Fault 1: 'error decoding RPC.\n\nnot well-formed
(invalid token) at line 1, column 8, byte 8 at
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/XML/Parser.pm
line 185\n'>

Expected results:

Query runs (as I have been doing at least weekly) and returns

Additional info:

Comment 1 Paul Nasrat 2004-01-28 16:39:58 UTC
Apologies wrong stack trace - I was running against a local bugzilla
instance.

I guess this is now closed down for external access:

xmlrpclib.ProtocolError: <ProtocolError for
bugzilla.redhat.com/bugzilla/xmlrpc.cgi: 403 Forbidden>

Can you confirm this is the case.


Comment 2 Paul Nasrat 2004-01-28 16:57:05 UTC
OK, bugtool was set to go against http not https by default (will let
jrb know).  Tested with a clean install of bugtool s/http/https/ and
ensured pointing at bugzilla.redhat.com back to original error:

xmlrpclib.Fault: <Fault 1: 'error decoding RPC.\n\nnot well-formed
(invalid token) at line 1, column 8, byte 8 at
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/XML/Parser.pm
line 185\n'

sorry for the line noise.

Comment 3 Paul Nasrat 2004-02-03 11:48:39 UTC
Retested today without changing anything this end is now working fine.

Closing as WORKSFORME as can't really say anything else

Comment 4 David Lawrence 2004-02-03 16:18:51 UTC
There was an error in the way the CGI data was being parsed. Something
was adding a POSTDATA= to the beginning of the POST body which was
causing the XMLRPC libraries to freak out. Removal of the POSTDATA=
from the beginning of the string using a regex allowed everything to
work again. Still looking into why that was being added in the first
place since the regex is considered a workaround and not a fix.


Note You need to log in before you can comment on or make changes to this bug.