Bug 1144790 - SELinux is preventing /usr/bin/bash from 'write' accesses on the file .
SELinux is preventing /usr/bin/bash from 'write' accesses on the file .
Status: CLOSED DUPLICATE of bug 1016831
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:131e2ca91bd7f8d5a434dd9ff96...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-20 21:08 EDT by Pedro
Modified: 2015-01-03 09:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-03 09:57:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro 2014-09-20 21:08:53 EDT
Description of problem:
SELinux is preventing /usr/bin/bash from 'write' accesses on the file .

*****  Plugin catchall (100. confidence) suggests   **************************

If você acredita que o bash deva ser permitido acesso de write em  file  por default.
Then você precisa reportar este como um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso agora executando:
# grep laptop_mode /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:apmd_t:s0
Target Context                system_u:object_r:var_lock_t:s0
Target Objects                 [ file ]
Source                        laptop_mode
Source Path                   /usr/bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.47-3.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-183.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.16.2-200.fc20.x86_64 #1 SMP Mon
                              Sep 8 11:54:45 UTC 2014 x86_64 x86_64
Alert Count                   7
First Seen                    2014-09-20 21:57:51 BRT
Last Seen                     2014-09-20 21:59:52 BRT
Local ID                      5f0c56fd-55e7-46be-9573-ba75d4aacddc

Raw Audit Messages
type=AVC msg=audit(1411261192.674:418): avc:  denied  { write } for  pid=3917 comm="laptop_mode" name="lmt-req.lock" dev="tmpfs" ino=17647 scontext=system_u:system_r:apmd_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1411261192.674:418): arch=x86_64 syscall=open success=no exit=EACCES a0=dcfa60 a1=201 a2=1b6 a3=1 items=0 ppid=3915 pid=3917 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=laptop_mode exe=/usr/bin/bash subj=system_u:system_r:apmd_t:s0 key=(null)

Hash: laptop_mode,apmd_t,var_lock_t,file,write

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.2-200.fc20.x86_64
type:           libreport

Potential duplicate: bug 1016831
Comment 1 Daniel Walsh 2015-01-03 09:57:44 EST

*** This bug has been marked as a duplicate of bug 1016831 ***

Note You need to log in before you can comment on or make changes to this bug.