Bug 114501 - Installed kernel boots but hangs while finding modules dependencies
Installed kernel boots but hangs while finding modules dependencies
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-01-28 15:15 EST by Sven Paas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 16:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sven Paas 2004-01-28 15:15:32 EST
Description of problem:

After successfully installing FC1 on my old Fujitsu-Siemens T-Bird, 
the installed kernel boots but hangs very lately while

"Finding module dependencies". 

The system works very well under Red Hat Linux 8 and Windows 2000 


- Intel Pentium II-MMX, 400 MHz, 384 MB RAM
- Intel 82371AB/EB PCI-to-ISA Bridge
  - Siemens I-Surf 2 ISA ISDN Card
- Intel 82443BX Pentium II to AGP Controller
  - ATI 3D Rage IIc AGP Graphics Adapter
- Intel 82443BX Pentium II to PCI Bridge
  - Intel 82371AB/EB PCI Bus-Master-IDE Controller
    - ST310230A Hard Drive
  - Intel 82371AB/EB PCI Bus-Master-IDE Controller
    - ST310230A Hard Drive
  - DawiCOntrol DC-2975U PCI SCSI Hostadapter (Symbios Logic 53c875)
    - IBM DCAS-34330 SCSI Hard Drive
    - YAMAHA CRW64165 SCSI CD Writer
  - Genius GF100TXR Super 10/100M PCI FastEthernet Adapter
    (RealTek RTL8139(A))
  - ESS Solo1 PCI Sound Card
- Intel 82371AB/EB PCI-to-USB Hostcontroller
  - USB Root Hub
- 2 serial ports, 1 parallel port, 1 floppy drive

I tried the following options with _no_ success: 

- noapic
- nousb
- apm=off
- acpi=off
- nopcmcia

I also removed all modules but 53c8xx.o from /etc/modules.conf, no 

Installation worked absolutely smoothly. 
The rescue system boots fine. 

I tried the kernel versions 2115 and 2149. 

Any hints? 

Version-Release number of selected component (if applicable):

kernel-2.4.22-1.2115.nptl and up. 

How reproducible:


Steps to Reproduce:
1. Install plain FC1
2. Reboot
Actual results:
System hangs after saying
"Finding modules dependencies."

Expected results:
System should boot. 

Additional info:
Same result with a fully patched FC1 up to 20040127. 
Nothing in /var/log/messages.
Comment 1 Dave Jones 2004-06-19 11:34:11 EDT
does the current errata kernel make any improvement? 
Comment 2 David Lawrence 2004-09-29 16:01:18 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.