Bug 1145104 - gnome-packagekit-updater: The package id's '' are not valid
Summary: gnome-packagekit-updater: The package id's '' are not valid
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-22 11:49 UTC by Brian J. Murrell
Modified: 2015-09-17 16:55 UTC (History)
19 users (show)

Fixed In Version: 3.16.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-16 21:21:17 UTC


Attachments (Terms of Use)
first attempt at gpk-update-viewer --verbose (757 bytes, text/plain)
2014-12-15 12:06 UTC, Brian J. Murrell
no flags Details
second attempt at gpk-update-viewer --verbose (41.92 KB, text/plain)
2014-12-15 12:07 UTC, Brian J. Murrell
no flags Details
gpk-update-viewer --verbose (42.79 KB, text/plain)
2015-04-04 14:52 UTC, Philip
no flags Details

Description Brian J. Murrell 2014-09-22 11:49:17 UTC
Description of problem:
gnome-packagekit-updater always reports: The package id's '' are not valid

Version-Release number of selected component (if applicable):
gnome-packagekit-updater-3.12.2-1.fc20.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start gpk-update-viewer
2. select/de-select packages to install
3. Click Install Updates

Actual results:
Dialog box pops up:

Could not update packages

Failed to process Request

More details
The package id's '' are not valid

Expected results:
Installs selected updates

Additional info:
I do know about gnome-software however it has several functional regressions over gpk-update-viewer that prevent me from using it.

Comment 1 Richard Hughes 2014-12-15 09:18:30 UTC
Can you attach the full logs of "gpk-update-viewer --verbose" when you can reproduce the problem please. Thanks.

Comment 2 Brian J. Murrell 2014-12-15 12:06:31 UTC
Created attachment 968927 [details]
first attempt at gpk-update-viewer --verbose

First attempt at running gpk-update-viewer --verbose.  First attempt at running this tool usually fails (i.e. exits after error) and then one needs a second one.

Comment 3 Brian J. Murrell 2014-12-15 12:07:57 UTC
Created attachment 968928 [details]
second attempt at gpk-update-viewer --verbose

This one is the one that reproduces the issue described in this ticket.  I selected two packages for update and then got the described error when I tried to install the updates.

Comment 4 Julian Sikorski 2015-01-04 07:20:51 UTC
Same here. pkcon update works fine.

$ gpk-update-viewer --verbose
08:19:30	GnomePackageKit     Verbose debugging enabled (on console 1)
08:19:30	GnomePackageKit     using native mode: -1x800
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated. please move it to /home/julas/.config/fontconfig/fonts.conf manually
08:19:30	GnomePackageKit     wrap_width is impossibly small -200
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
08:19:30	GnomePackageKit     only showing newest updates
08:19:30	GnomePackageKit     wrap_width is impossibly small -200
08:19:30	GnomePackageKit     status wait
08:19:30	GnomePackageKit     wrap_width is impossibly small -200
08:19:30	GnomePackageKit     status setup
08:19:30	GnomePackageKit     status finished
08:19:30	GnomePackageKit     adding: id=gettext;0.19.4-2.fc21;x86_64;updates, text=GNU libraries and utilities for producing multi-lingual messages
<span color="#8d9091">gettext-0.19.4-2.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=gettext-common-devel;0.19.4-2.fc21;noarch;updates, text=Common development files for gettext
<span color="#8d9091">gettext-common-devel-0.19.4-2.fc21</span>
08:19:30	GnomePackageKit     adding: id=gettext-devel;0.19.4-2.fc21;x86_64;updates, text=Development files for gettext
<span color="#8d9091">gettext-devel-0.19.4-2.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=gettext-libs;0.19.4-2.fc21;x86_64;updates, text=Libraries for gettext
<span color="#8d9091">gettext-libs-0.19.4-2.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=libssh;0.6.4-1.fc21;x86_64;updates, text=A library implementing the SSH protocol
<span color="#8d9091">libssh-0.6.4-1.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=liveusb-creator;3.13.2-1.fc21;noarch;updates, text=A liveusb creator
<span color="#8d9091">liveusb-creator-3.13.2-1.fc21</span>
08:19:30	GnomePackageKit     adding: id=mailx;12.5-14.fc21;x86_64;updates, text=Enhanced implementation of the mailx command
<span color="#8d9091">mailx-12.5-14.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=perl-Encode;1:2.67-1.fc21;x86_64;updates, text=Character encodings in Perl
<span color="#8d9091">perl-Encode-1:2.67-1.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=perl-YAML-Syck;1.28-1.fc21;x86_64;updates, text=Fast, lightweight YAML loader and dumper
<span color="#8d9091">perl-YAML-Syck-1.28-1.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=procps-ng;3.3.10-5.fc21;x86_64;updates, text=System and process monitoring utilities
<span color="#8d9091">procps-ng-3.3.10-5.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=scl-utils;20140815-4.fc21;x86_64;updates, text=Utilities for alternative packaging
<span color="#8d9091">scl-utils-20140815-4.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     adding: id=shared-color-targets;0.1.5-1.fc21;noarch;updates, text=Shared color targets for creating color profiles
<span color="#8d9091">shared-color-targets-0.1.5-1.fc21</span>
08:19:30	GnomePackageKit     adding: id=slrn;1.0.2-1.fc21;x86_64;updates, text=A threaded Internet news reader
<span color="#8d9091">slrn-1.0.2-1.fc21 (64-bitowy)</span>
08:19:30	GnomePackageKit     network status is wifi
08:19:30	GnomePackageKit     wrap_width is impossibly small -172
08:19:30	GnomePackageKit     status wait
08:19:30	GnomePackageKit     status wait
08:19:30	GnomePackageKit     wrap_width is impossibly small -172
08:19:30	GnomePackageKit     status setup
08:19:30	GnomePackageKit     status query
08:19:30	GnomePackageKit     status loading-cache
08:19:31	GnomePackageKit     status finished
08:19:31	GnomePackageKit     status setup
08:19:31	GnomePackageKit     status finished
08:19:31	GnomePackageKit     network status is wifi
08:19:31	GnomePackageKit     wrap_width is impossibly small -108
08:19:39	GnomePackageKit     Doing the package updates
08:19:39	GnomePackageKit     status wait
08:19:39	GnomePackageKit     status finished
08:19:39	GnomePackageKit     Nie można zaktualizować pakietów: The package id's '' are not valid
08:19:39	GnomePackageKit     wrap_width is impossibly small -108

Comment 5 Daniel 2015-01-08 11:31:03 UTC
After upgraded to Fedora 21, I had the same problem.
Here is what I installed:
$ rpm -qa | grep -i packagekit
PackageKit-command-not-found-1.0.3-4.fc21.x86_64
PackageKit-glib-1.0.3-4.fc21.x86_64
gnome-packagekit-installer-3.14.2-1.fc21.x86_64
eclipse-packagekit-0.1.0-7.fc21.noarch
gnome-packagekit-updater-3.14.2-1.fc21.x86_64
PackageKit-1.0.3-4.fc21.x86_64
gnome-packagekit-3.14.2-1.fc21.x86_64
PackageKit-gstreamer-plugin-1.0.3-4.fc21.x86_64
PackageKit-gtk3-module-1.0.3-4.fc21.x86_64


Here is my console result of gpk-update-viewer -v:
$ gpk-update-viewer -v
20:05:01	GnomePackageKit     Verbose debugging enabled (on console 1)
20:05:01	GnomePackageKit     using native mode: -1x800
20:05:01	GnomePackageKit     wrap_width is impossibly small -200
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
20:05:01	GnomePackageKit     only showing newest updates
20:05:01	GnomePackageKit     wrap_width is impossibly small -200
20:05:01	GnomePackageKit     status wait
20:05:01	GnomePackageKit     wrap_width is impossibly small -200
20:05:01	GnomePackageKit     status setup
20:05:01	GnomePackageKit     status finished
20:05:01	GnomePackageKit     adding: id=NetworkManager;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=Network connection manager and user applications
<span color="#7f7f7f">NetworkManager-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-adsl;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=ADSL device plugin for NetworkManager
<span color="#7f7f7f">NetworkManager-adsl-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-bluetooth;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=Bluetooth device plugin for NetworkManager
<span color="#7f7f7f">NetworkManager-bluetooth-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-config-connectivity-fedora;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=NetworkManager config file for connectivity checking via Fedora servers
<span color="#7f7f7f">NetworkManager-config-connectivity-fedora-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-devel;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=Libraries and headers for adding NetworkManager support to applications
<span color="#7f7f7f">NetworkManager-devel-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-glib;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=Libraries for adding NetworkManager support to applications that use glib.
<span color="#7f7f7f">NetworkManager-glib-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-glib-devel;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=Header files for adding NetworkManager support to applications that use glib.
<span color="#7f7f7f">NetworkManager-glib-devel-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-wifi;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=Wifi plugin for NetworkManager
<span color="#7f7f7f">NetworkManager-wifi-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=NetworkManager-wwan;1:0.9.10.1-1.git20150105.fc21;x86_64;updates, text=Mobile broadband device plugin for NetworkManager
<span color="#7f7f7f">NetworkManager-wwan-1:0.9.10.1-1.git20150105.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=bash;4.3.33-1.fc21;x86_64;updates, text=The GNU Bourne Again shell
<span color="#7f7f7f">bash-4.3.33-1.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=gdal-libs;1.11.1-5.fc21;x86_64;updates, text=GDAL file format library
<span color="#7f7f7f">gdal-libs-1.11.1-5.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=gdal-python;1.11.1-5.fc21;x86_64;updates, text=Python modules for the GDAL file format library
<span color="#7f7f7f">gdal-python-1.11.1-5.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=hwdata;0.273-1.fc21;noarch;updates, text=Hardware identification and configuration data
<span color="#7f7f7f">hwdata-0.273-1.fc21</span>
20:05:01	GnomePackageKit     adding: id=initscripts;9.56.1-6.fc21;x86_64;updates, text=Scripts to bring up network interfaces
<span color="#7f7f7f">initscripts-9.56.1-6.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=kde-settings;21-2.fc21;noarch;updates, text=Config files for kde
<span color="#7f7f7f">kde-settings-21-2.fc21</span>
20:05:01	GnomePackageKit     adding: id=libgeotiff;1.4.0-2.fc21;x86_64;updates, text=GeoTIFF format library
<span color="#7f7f7f">libgeotiff-1.4.0-2.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=libical;1.0-8.fc21;x86_64;updates, text=Reference implementation of the iCalendar data type and serialization format
<span color="#7f7f7f">libical-1.0-8.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=libical-devel;1.0-8.fc21;x86_64;updates, text=Development files for libical
<span color="#7f7f7f">libical-devel-1.0-8.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=libteam;1.15-1.fc21;x86_64;updates, text=Library for controlling team network device
<span color="#7f7f7f">libteam-1.15-1.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=mariadb;1:10.0.15-3.fc21;x86_64;updates, text=A community developed branch of MySQL
<span color="#7f7f7f">mariadb-1:10.0.15-3.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=mariadb-common;1:10.0.15-3.fc21;x86_64;updates, text=The shared files required by server and client
<span color="#7f7f7f">mariadb-common-1:10.0.15-3.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=mariadb-config;1:10.0.15-3.fc21;x86_64;updates, text=The config files required by server and client
<span color="#7f7f7f">mariadb-config-1:10.0.15-3.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=mariadb-devel;1:10.0.15-3.fc21;x86_64;updates, text=Files for development of MariaDB/MySQL applications
<span color="#7f7f7f">mariadb-devel-1:10.0.15-3.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=mariadb-libs;1:10.0.15-3.fc21;x86_64;updates, text=The shared libraries required for MariaDB/MySQL clients
<span color="#7f7f7f">mariadb-libs-1:10.0.15-3.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=mpfr;3.1.2-8.fc21;x86_64;updates, text=A C library for multiple-precision floating-point computations
<span color="#7f7f7f">mpfr-3.1.2-8.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=perl-Filter;1:1.53-1.fc21;x86_64;updates, text=Perl source filters
<span color="#7f7f7f">perl-Filter-1:1.53-1.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=phpMyAdmin;4.3.5-1.fc21;noarch;updates, text=Handle the administration of MySQL over the World Wide Web
<span color="#7f7f7f">phpMyAdmin-4.3.5-1.fc21</span>
20:05:01	GnomePackageKit     adding: id=ppp;2.4.7-6.fc21;x86_64;updates, text=The Point-to-Point Protocol daemon
<span color="#7f7f7f">ppp-2.4.7-6.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=ppp-devel;2.4.7-6.fc21;x86_64;updates, text=Headers for ppp plugin development
<span color="#7f7f7f">ppp-devel-2.4.7-6.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=pykickstart;1.99.65-2.fc21;noarch;updates, text=A python library for manipulating kickstart files
<span color="#7f7f7f">pykickstart-1.99.65-2.fc21</span>
20:05:01	GnomePackageKit     adding: id=qt-settings;21-2.fc21;noarch;updates, text=Configuration files for Qt
<span color="#7f7f7f">qt-settings-21-2.fc21</span>
20:05:01	GnomePackageKit     adding: id=redis;2.8.18-1.fc21;x86_64;updates, text=A persistent key-value database
<span color="#7f7f7f">redis-2.8.18-1.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=tcpdump;14:4.6.2-3.fc21;x86_64;updates, text=A network traffic monitoring tool
<span color="#7f7f7f">tcpdump-14:4.6.2-3.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     adding: id=teamd;1.15-1.fc21;x86_64;updates, text=Team network device control daemon
<span color="#7f7f7f">teamd-1.15-1.fc21 (64-bit)</span>
20:05:01	GnomePackageKit     network status is wired
20:05:01	GnomePackageKit     wrap_width is impossibly small -160
20:05:01	GnomePackageKit     status wait
20:05:01	GnomePackageKit     wrap_width is impossibly small -160
20:05:01	GnomePackageKit     status wait
20:05:01	GnomePackageKit     status setup
20:05:02	GnomePackageKit     status finished
20:05:02	GnomePackageKit     status setup
20:05:03	GnomePackageKit     status finished
20:05:03	GnomePackageKit     network status is wired
20:05:03	GnomePackageKit     wrap_width is impossibly small -97
20:05:05	GnomePackageKit     Doing the package updates
20:05:05	GnomePackageKit     wrap_width is impossibly small -97
20:05:05	GnomePackageKit     status wait
20:05:05	GnomePackageKit     status finished
20:05:05	GnomePackageKit     Could not update packages: The package id's '' are not valid

Comment 6 Alfredo Ferrari 2015-01-10 08:58:05 UTC
Same problem for me on 3 fullly up-to-date Fedora 21 installations, 2 desktops (one fresh install, one updated with fedup) and one laptop. No issue in Fedora 20

Comment 7 Venelin Stoykov 2015-02-11 22:09:05 UTC
I have the same problem after upgrading to Fedora 21. Also Gnome Software can't install packages and can't update packages. I need to use yum or yumex (if I want GUI).

Comment 8 Won Young Choi 2015-02-25 00:32:02 UTC
I have  same issue with F21(upgraded from F20).

[wchoi@wchoi ~]$ gpk-update-viewer --verbose
09:24:12	GnomePackageKit     Verbose debugging enabled (on console 1)
09:24:12	GnomePackageKit     using native mode: -1x800
09:24:12	GnomePackageKit     wrap_width is impossibly small -200
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
09:24:12	GnomePackageKit     only showing newest updates
09:24:12	GnomePackageKit     wrap_width is impossibly small -200
09:24:12	GnomePackageKit     status wait
09:24:12	GnomePackageKit     status setup
09:24:12	GnomePackageKit     wrap_width is impossibly small -200
09:24:12	GnomePackageKit     status finished
09:24:12	GnomePackageKit     adding: id=dhclient;12:4.3.1-12.fc21;x86_64;updates, text=Provides the ISC DHCP client daemon and dhclient-script
<span color="#8d9091">dhclient-12:4.3.1-12.fc21 (64-bit)</span>
09:24:12	GnomePackageKit     adding: id=dhcp-common;12:4.3.1-12.fc21;x86_64;updates, text=Common files used by ISC dhcp client and server
<span color="#8d9091">dhcp-common-12:4.3.1-12.fc21 (64-bit)</span>
09:24:12	GnomePackageKit     adding: id=dhcp-libs;12:4.3.1-12.fc21;x86_64;updates, text=Shared libraries used by ISC dhcp client and server
<span color="#8d9091">dhcp-libs-12:4.3.1-12.fc21 (64-bit)</span>
09:24:12	GnomePackageKit     adding: id=gtk2;2.24.26-1.fc21;x86_64;updates, text=The GIMP ToolKit (GTK+), a library for creating GUIs for X
<span color="#8d9091">gtk2-2.24.26-1.fc21 (64-bit)</span>
09:24:12	GnomePackageKit     adding: id=perl-Pod-Parser;1.63-1.fc21;noarch;updates, text=Basic perl modules for handling Plain Old Documentation (POD)
<span color="#8d9091">perl-Pod-Parser-1.63-1.fc21</span>
09:24:12	GnomePackageKit     adding: id=perl-Text-Autoformat;1.669007-1.fc21;noarch;updates, text=Automatic text wrapping and reformatting
<span color="#8d9091">perl-Text-Autoformat-1.669007-1.fc21</span>
09:24:12	GnomePackageKit     adding: id=perl-generators;1.03-1.fc21;noarch;updates, text=RPM Perl dependencies generators
<span color="#8d9091">perl-generators-1.03-1.fc21</span>
09:24:12	GnomePackageKit     adding: id=rygel;0.24.3-1.fc21;x86_64;updates, text=A collection of UPnP/DLNA services
<span color="#8d9091">rygel-0.24.3-1.fc21 (64-bit)</span>
09:24:12	GnomePackageKit     adding: id=sox;14.4.1-7.fc21;x86_64;updates, text=A general purpose sound file conversion tool
<span color="#8d9091">sox-14.4.1-7.fc21 (64-bit)</span>
09:24:12	GnomePackageKit     adding: id=usb_modeswitch;2.2.0-2.fc21;x86_64;updates, text=USB Modeswitch gets mobile broadband cards in operational mode
<span color="#8d9091">usb_modeswitch-2.2.0-2.fc21 (64-bit)</span>
09:24:12	GnomePackageKit     adding: id=usb_modeswitch-data;20150115-1.fc21;noarch;updates, text=USB Modeswitch gets mobile broadband cards in operational mode
<span color="#8d9091">usb_modeswitch-data-20150115-1.fc21</span>
09:24:12	GnomePackageKit     network status is wired
09:24:12	GnomePackageKit     wrap_width is impossibly small -172
09:24:12	GnomePackageKit     status wait
09:24:12	GnomePackageKit     status wait
09:24:12	GnomePackageKit     status setup
09:24:12	GnomePackageKit     wrap_width is impossibly small -172
09:24:12	GnomePackageKit     status finished
09:24:12	GnomePackageKit     status setup
09:24:12	GnomePackageKit     status finished
09:24:12	GnomePackageKit     network status is wired
09:24:12	GnomePackageKit     wrap_width is impossibly small -108
09:24:14	GnomePackageKit     Doing the package updates
09:24:14	GnomePackageKit     status wait
09:24:14	GnomePackageKit     status finished
09:24:14	GnomePackageKit     Could not update packages: The package id's '' are not valid
09:24:14	GnomePackageKit     wrap_width is impossibly small -108


but pkcon update works in terminal.

[wchoi@wchoi ~]$ pkcon update
Getting updates               [=========================]         
Finished                      [=========================]         
Starting                      [=========================]         
Testing changes               [=========================]         
Finished                      [=========================]         
Updating packages             [=========================]         
Querying                      [=========================]         
Downloading packages          [=========================]         
Testing changes               [=========================]         
Installing updates            [=========================]         
Finished                      [=========================] 
[wchoi@wchoi ~]$ sudo yum update -y
[sudo] password for wchoi: 
Loaded plugins: changelog, fastestmirror, langpacks, priorities, ps
Dropbox                                                                                                      |  951 B  00:00:00     
adobe-linux-x86_64                                                                                           |  951 B  00:00:00     
bluejeans                                                                                                    | 2.9 kB  00:00:00     
google-chrome                                                                                                |  951 B  00:00:00     
rpmfusion-free-updates                                                                                       | 2.7 kB  00:00:00     
rpmfusion-nonfree-updates                                                                                    | 2.7 kB  00:00:00     
updates/21/x86_64/metalink                                                                                   | 7.3 kB  00:00:00     
updates                                                                                                      | 4.9 kB  00:00:00     
updates/21/x86_64/primary_db                                                                                 | 5.3 MB  00:00:15     
(1/3): google-chrome/primary                                                                                 | 2.0 kB  00:00:00     
(2/3): updates/21/x86_64/updateinfo                                                                          | 644 kB  00:00:03     
(3/3): updates/21/x86_64/pkgtags                                                                             | 1.4 MB  00:00:05     
Loading mirror speeds from cached hostfile
 * fedora: ftp.tsukuba.wide.ad.jp
 * rpmfusion-free: mirror.hust.edu.cn
 * rpmfusion-free-updates: mirror.hust.edu.cn
 * rpmfusion-nonfree: mirrors.163.com
 * rpmfusion-nonfree-updates: mirror.hust.edu.cn
 * updates: ftp.yzu.edu.tw
google-chrome                                                                                                                   3/3
No packages marked for update
[wchoi@wchoi ~]$ 
[wchoi@wchoi ~]$ gpk-update-viewer --verbose
09:30:59	GnomePackageKit     Verbose debugging enabled (on console 1)
09:30:59	GnomePackageKit     using native mode: -1x800
09:30:59	GnomePackageKit     wrap_width is impossibly small -200
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
09:30:59	GnomePackageKit     only showing newest updates
09:30:59	GnomePackageKit     wrap_width is impossibly small -200
09:30:59	GnomePackageKit     status wait
09:30:59	GnomePackageKit     status setup
09:30:59	GnomePackageKit     status query
09:30:59	GnomePackageKit     wrap_width is impossibly small -200
09:30:59	GnomePackageKit     status loading-cache
09:30:59	GnomePackageKit     status finished
09:30:59	GnomePackageKit     network status is wired
09:30:59	GnomePackageKit     wrap_width is impossibly small -200
[wchoi@wchoi ~]$ 

no update from gpk-update-viewer.

Comment 9 Philip 2015-04-04 14:52:26 UTC
Created attachment 1010856 [details]
gpk-update-viewer --verbose

Same error on my Fedora systems:
GnomePackageKit	Could not update packages: The package id's '' are not valid

Output of "gpk-update-viewer --verbose" attached.

This should be fixed as soon as possible (this bug is already half a year old!). I'm not telling my friends to open a shell and type "sudo yum update". There should be a working gui for updating the system.

Comment 10 Rex Dieter 2015-04-04 15:12:18 UTC
I suspect this may help or mitigate things at least some:

http://fedoraproject.org/wiki/Common_F21_bugs#libhif-packagekit-broken

which requires you to install that update outside of PackageKit, via:
yum update --advisory=FEDORA-2015-0921

and then possibly run,  'pkcon repair'

Comment 11 Philip 2015-04-04 15:50:38 UTC
(In reply to Rex Dieter from comment #10)
> yum update --advisory=FEDORA-2015-0921

Thanks for the tip. I've just tried this, which returned with:
No packages needed for security; 228 packages available
Resolving Dependencies

Also, since that fedoraproject.org article mentioned libhif, I checked but there is no update available:
# yum install libhif
Loaded plugins: etckeeper, langpacks
Package libhif-0.1.8-4.fc21.x86_64 already installed and latest version
Nothing to do

Comment 12 Adri Verhoef 2015-04-08 16:54:37 UTC
I've ran "yum update --advisory=FEDORA-2015-0921" and "pkcon repair".
When I run "yum updateinfo list", I get:
$ yum updateinfo list | cut -c1-28 | uniq -c
      1 Loaded plugins: langpacks
      1 FEDORA-2015-5255 bugfix     
      3 FEDORA-2015-5243 bugfix     
      1 FEDORA-2015-4379 bugfix     
      2 FEDORA-2015-5065 bugfix     
      1 FEDORA-2015-4863 enhancement
     13 FEDORA-2015-5255 bugfix     
      2 FEDORA-2015-4658 security   
      1 FEDORA-2015-4288 bugfix     
      5 FEDORA-2015-5586 bugfix     
      2 FEDORA-2015-4838 security   
    228 FEDORA-2015-4872 security   
      1 FEDORA-2015-4923 enhancement
      1 FEDORA-2015-5578 enhancement
      1 updateinfo list done

So there's enough to update; but when I run "gpk-update-viewer --verbose", it tells me that "All packages are up to date" and "There are no package updates available for your computer at this time":

# gpk-update-viewer --verbose
18:37:45	GnomePackageKit     Verbose debugging enabled (on console 1)
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
18:37:48	GnomePackageKit     using native mode: -1x800
18:37:48	GnomePackageKit     wrap_width is impossibly small -200
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
18:37:48	GnomePackageKit     wrap_width is impossibly small -200
18:37:48	GnomePackageKit     only showing newest updates
18:37:48	GnomePackageKit     status wait
18:37:48	GnomePackageKit     wrap_width is impossibly small -200
18:37:48	GnomePackageKit     status setup
18:37:48	GnomePackageKit     status finished
18:37:48	GnomePackageKit     network status is wired
18:37:48	GnomePackageKit     wrap_width is impossibly small -200

However, when I run "yum update", there's plenty of updates:
# yum check-update | grep updates$ | wc
    262     782   21222

Comment 13 Adri Verhoef 2015-04-08 16:58:43 UTC
Forgot to add:

yum-3.4.3-153.fc21.noarch
gnome-packagekit-updater-3.14.2-1.fc21.x86_64
libhif-0.1.8-4.fc21.x86_64

Comment 14 Adri Verhoef 2015-04-08 17:00:09 UTC
Anyway, the problem "gnome-packagekit-updater always reports: The package id's '' are not valid" has been fixed (for me).

Comment 15 Tom Porter 2015-04-22 16:13:36 UTC
The update to libhif does NOT appear to fix this (at least for me). I have ensured that I have:

libhif-0.1.8-4.fc21.i686
yum-3.4.3-153.fc21.noarch
gnome-packagekit-updater-3.14.2-1.fc21.i686

and that I have executed `pkcon repair` and rebooted.

Updates attempted via the GUI still report an error:

"The package id's '' are not valid"

Comment 16 Edward Rudd 2015-05-12 22:17:27 UTC
This also occurs for me in F21. As well as the packagekit never pulling updates.. (I have to do a 'pkcon -c 1 refresh' to get new updates).. It makes it REALLY hard to apply updates to a system when the update system is so horribly broken.

Comment 17 Matthias Clasen 2015-05-28 02:18:03 UTC
diff --git a/src/gpk-update-viewer.c b/src/gpk-update-viewer.c
index e751022..9b08f18 100644
--- a/src/gpk-update-viewer.c
+++ b/src/gpk-update-viewer.c
@@ -1103,6 +1103,7 @@ gpk_update_viewer_info_is_update_enum (PkInfoEnum
info)
 {
        gboolean ret = FALSE;
        switch (info) {
+       case PK_INFO_ENUM_AVAILABLE:
        case PK_INFO_ENUM_LOW:
        case PK_INFO_ENUM_NORMAL:
        case PK_INFO_ENUM_IMPORTANT:

This patch fixes the problem on my system.

Comment 18 Daniel 2015-05-28 09:57:45 UTC
Bad news, the patch on Comment 17 does not work for me.

Comment 19 Fedora End Of Life 2015-05-29 12:56:24 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 20 Sylvain Petreolle 2015-07-03 21:27:25 UTC
This happens in Fedora 22 too. Please update the version.
gnome-packagekit-updater-3.16.0-1.fc22.x86_64
libhif-0.2.0-4.fc22.x86_64

Comment 21 Julian Sikorski 2015-07-22 06:33:50 UTC
Daniel, please may you check again? I have tested patch from comment #17 and it did fix the problem.

Comment 22 Daniel 2015-07-23 11:25:30 UTC
Thank you very much for your contact.
I patched comment 17 on gnome-packagekit-3.16.0-1.fc22, and it works now.

Comment 23 Brian J. Murrell 2015-07-23 11:48:50 UTC
So if the fix in comment #17 is correct, what is the next steps to get this fix into the wild?

Comment 24 Brian J. Murrell 2015-07-23 12:21:15 UTC
Anyone looking for a build with the patch in comment #17 included can get it from here: https://copr.fedoraproject.org/coprs/brianjmurrell/gnome-packagekit/

It works here.

Comment 25 Sylvain Petreolle 2015-08-03 22:41:07 UTC
(In reply to Brian J. Murrell from comment #24)
> Anyone looking for a build with the patch in comment #17 included can get it
> from here:
> https://copr.fedoraproject.org/coprs/brianjmurrell/gnome-packagekit/
> 
> It works here.

I confirm your copr packages fix the issue.
Thanks Matthias & Brian.

Comment 26 Kalev Lember 2015-08-30 14:12:05 UTC
I've backported the patch to gnome-packagekit-3.16.0-2.fc22 as well now. Sorry that this fell through the cracks!

Comment 27 Fedora Update System 2015-08-30 14:15:33 UTC
gnome-packagekit-3.16.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14579

Comment 28 Fedora Update System 2015-09-01 09:58:39 UTC
gnome-packagekit-3.16.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update gnome-packagekit'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14579

Comment 29 Fedora Update System 2015-09-16 21:21:12 UTC
gnome-packagekit-3.16.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 Sylvain Petreolle 2015-09-17 16:55:27 UTC
Thanks for the support.


Note You need to log in before you can comment on or make changes to this bug.