Bug 1145137 - Can not select multiple LDAP servers with authconfig
Summary: Can not select multiple LDAP servers with authconfig
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
: 1203199 (view as bug list)
Depends On: 1142830
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-22 13:10 UTC by David Spurek
Modified: 2019-07-11 08:12 UTC (History)
7 users (show)

Fixed In Version: authconfig-6.1.12-20.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1142830
Environment:
Last Closed: 2015-03-31 07:05:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0760 normal SHIPPED_LIVE authconfig bug fix update 2015-03-31 11:05:15 UTC

Description David Spurek 2014-09-22 13:10:42 UTC
Similar problem in rhel6, tested with authconfig-6.1.12-19.el6

### sssd check: ###
1)authconfig --enablesssd --enablesssdauth --update
2)authconfig --enableldap --enableldapauth  --ldapserver='ldap://ldap1.example.com ldap://ldap2.example.com ldap://ldap3.example.com' --ldapbasedn="dc=example,dc=com" --update --nostart

a) The second command ends with 'authconfig: Invalid LDAP URI.', but return code is zero and it should return non zero code.
b) Even if authconfig ends with 'authconfig: Invalid LDAP URI.', sssd.conf has correct ldap_uri value (ldap_uri = ldap://ldap1.example.com,ldap://ldap2.example.com,ldap://ldap3.example.com)

### nss-pam-ldapd check: ###
authconfig --enableldap --enableldapauth  --ldapserver='ldap://ldap1.example.com ldap://ldap2.example.com ldap://ldap3.example.com' --ldapbasedn="dc=example,dc=com" --update --nostart --enableforcelegacy

c) command ends with 'authconfig: Invalid LDAP URI.', but return code is zero and it should return non zero code.
d)uri entry in nslcd.conf is wrong, current entry is 'uri ldap://ldap1.example.com ldap://ldap2.example.com ldap://ldap3.example.com' but it should be splitted to 3 lines:
uri ldap://ldap1.example.com
uri ldap://ldap2.example.com
uri ldap://ldap3.example.com



+++ This bug was initially created as a clone of Bug #1142830 +++

Description of problem:
Can not select multiple LDAP servers with authconfig

Version-Release number of selected component (if applicable):
authconfig-6.2.8-8.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
 
[root@dhcp210-38 ~]# authconfig --enableldap --enableldapauth  --ldapserver='ldap://ldap1.example.com ldap://ldap2.example.com ldap://ldap3.example.com' --ldapbasedn="dc=example,dc=com" --update
authconfig: Invalid LDAP URI.
Job for nslcd.service failed. See 'systemctl status nslcd.service' and 'journalctl -xn' for details.

[root@dhcp210-38 ~]# authconfig --enableldap --enableldapauth  --ldapserver='ldap://ldap1.example.com,ldap://ldap2.example.com,ldap://ldap3.example.com' --ldapbasedn="dc=example,dc=com" --update
authconfig: Invalid LDAP URI.
Job for nslcd.service failed. See 'systemctl status nslcd.service' and 'journalctl -xn' for details.

Actual results:
Authconfig now takes only one LDAP server in arguement. 

Expected results:
authconfig should take multiple server in arguement.

--- Additional comment from David Spurek on 2014-09-17 10:03:19 EDT ---

nslcd.conf man page says following about multiple uri:
This  option may be specified multiple times. Normally, only the first server will be used with the following  servers  as  fallback (see bind_timelimit below).

We should simply add 3 uri entries to nslcd.conf

This option may also influence sssd.conf.
sssd may also take multiple ldap uris but it has different syntax. It takes comma-separated list of URIs.

Comment 6 Tomas Mraz 2015-03-18 13:04:41 UTC
*** Bug 1203199 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2015-03-31 07:05:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0760.html


Note You need to log in before you can comment on or make changes to this bug.