Bug 1145229 - Set Operating System when creating new VMs in RHEV Compute Resource
Summary: Set Operating System when creating new VMs in RHEV Compute Resource
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1315281 1317530
TreeView+ depends on / blocked
 
Reported: 2014-09-22 15:14 UTC by Vladimir Vasilev
Modified: 2019-12-16 04:33 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1315281 (view as bug list)
Environment:
Last Closed: 2017-05-19 12:45:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 6959 0 None None None 2016-04-26 16:55:17 UTC

Description Vladimir Vasilev 2014-09-22 15:14:35 UTC
Description of problem:
When provisioning new RHEL VM to RHEV Compute Resource the newly created instance has Operating System set to "Other OS". In Satellite the operating system is configured as:
Name: RedHat
Major version: 6
Minor version: 5
Description: RHEL 6.5
OS Family: Red Hat
Architectures: x86_64

I had to change parameters in RHEV which are available only for Linux (for example kernel/initrd) and it's not possible if the VM is listed as "Other OS".

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. In Satellite create Operating System part of Red Hat family. 
2. Provision new VM with Operating System from step 1 in RHEV Compute Resource.
3. Login to RHEV-M and check the actual value of "Operating System" for that VM.

Actual results:
Operating System is set to "Other OS"

Expected results:
Operating System is set to "Red Hat Enterprise Linux 6.x x64"

Additional info:

Comment 1 RHEL Program Management 2014-09-22 15:33:22 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-09-23 07:54:19 UTC
Connecting redmine issue http://projects.theforeman.org/issues/6959 from this bug

Comment 4 Bryan Kearney 2015-08-25 18:08:03 UTC
Upstream bug component is Compute Resources

Comment 7 Ivan Necas 2016-04-12 11:19:11 UTC
The patches were merged upstream:

https://github.com/theforeman/foreman/pull/3308
https://github.com/abenari/rbovirt/pull/104
https://github.com/abenari/rbovirt/pull/106

Since the change was not that trivial, I advice not getting it into 6.1+ as it might cause conflicts with other potential 6.1+ backports later and lead to some instabilities.

Comment 8 Bryan Kearney 2017-05-19 12:45:30 UTC
We will not be addressing this bug in the 6.1 code base. If you have concerns with this, please feel free to reach out to me with any concerns or issues you may have. Thank you.


Note You need to log in before you can comment on or make changes to this bug.