Bug 11453 - Big bug with the boot and aic7xxx module!!
Big bug with the boot and aic7xxx module!!
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 2000-05-16 17:01 EDT by Christian
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-14 18:24:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christian 2000-05-16 17:01:17 EDT
I've installed several times the RedHat 6.0/6.1/6.2 and the installation
successed every time. But when the system reboots, the loading process
doesn't finish. It appears to me:

loading aic7xxx module...
(scsi0) <Adaptec AHA-294X Ultra SCSI host adapter> found at PCI 0/14/0
(scsi0) Wide channel, SCSI ID=7, 16/255 SCBs
        Downloading sequence code... 423 instructions downloaded
enable-IRQ() unbalanced from C881b401
scsi0 : Adaptec AHA 274X/284X/294X (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
        <Adaptec AHA-294X Ultra SCSI host adapter>
scsi : 1 host
scsi : aborting command due to timeout: pid0, scsi0, channel0, id0, lun0,
       Test Unit Ready 00 00 00 00 00
SCSI host0 channel0 reset (pid0) timed out - trying harder
SCSI bus is being reset for host0 channel0
SCSI host0 abort (pid0) timed out - resetting

and the last three lines repeat infinitly!
I have a PC with this configuration:

MotherBoard: Tyan S1668 iFX dual processor
CPU: iPentium PRO 200 Mhz (256Kb)
RAM: 128Mb FastPage
Host Adapter: Ataptec AHA-2940 Ultra Wide (PCI)
10HD: Quantum Vicking II 4.5Gb (SCSI ID=0)
20HD: Quantum Vicking II 4.5Gb (SCSI ID=1)
30HD: Quantum Atlas 2.1Gb      (SCSI ID=2)
Cdrom Writer: Ricoh            (SCSI ID=4)
Cdrom Drive: Pioneer           (SCSI ID=5)

This problem also appears when I install the Mandrake 7 and the SuSE
6.3... otherwise the Slackware 7 runs correctly... why?

I hope you can give me an answer quickly because I enjoy your product.
Thank you;

Christian D.P.L.
Comment 1 joe 2000-07-14 14:29:52 EDT
I get the exact same
Comment 2 joe 2000-07-14 14:36:42 EDT
I get the exact same errors when I try to install either 6.0 or 6.2.

My system is an IBM Netfinity 3000 with an on board AHA-294x controller (1.32S8 
bios) and a Seagate ST39204LW drive. 

I've tried the latest updates of the aic7xxx module, but get the same result.

Caldera and SUSE don't work either, but Windows 98 and 2000 install easily.

I have another (much older) machine running 6.2 and would like to have it on 
another machine, but haven't had any luck after days of trying to get either 
4.2, 6.0 or 6.2 on the machine.
Comment 3 Need Real Name 2000-08-17 14:16:14 EDT
I fixed mine by overwriting the aic7xxx files (and directory) in the source
distro with the ones from RH 6.1.  A pain to get ahold of them, but once I did,
I then re-compiled the kernel and the aic problems went away.
Comment 4 Need Real Name 2001-03-19 10:33:03 EST
I have the same problem, when I connect a CD reader on a SE connector and not on
a LVD/SE connector the system looks for Disks and after CDs and repeat that all
the time.
When I install Linux without CD and after reconnect CD I have a time out error
Comment 5 Arjan van de Ven 2001-03-19 10:36:31 EST
arnal: could you specify what Red Hat Linux / kernel version this is?
Comment 6 Alan Cox 2002-12-14 18:24:41 EST
No answer in a very very long time


Alan the bugzilla womble

Note You need to log in before you can comment on or make changes to this bug.