Bug 114533 - USB initialization prints FAILED under kernel 2.6
USB initialization prints FAILED under kernel 2.6
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 03:50 EST by Gary Peck
Modified: 2014-03-16 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.44-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 11:31:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gary Peck 2004-01-29 03:50:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20040105 Firebird/0.7

Description of problem:
The USB loading section on lines 204-209 in rc.sysinit fails on 2.6
kernels. Specifically, the fgrep on /proc/bus/usb/drivers fails
because that file doesn't exist. modprobe keybdev and modprobe
mousedev also both fail because those modules don't exist in 2.6. I'm
using uhci-hcd as my USB module.

Version-Release number of selected component (if applicable):
initscripts-7.43-2

How reproducible:
Always

Steps to Reproduce:
1. Install this initscripts and a 2.6 kernel
2. Reboot
3. Watch the status messages scroll by
    

Actual Results:  Around the USB initialization section, you'll see two
red FAILED's and an error from fgrep.

Expected Results:  It should pass since this failure is actually
harmless on a 2.6 kernel.

Additional info:

This is with kernel-2.6.1-1.61.
Comment 1 Bill Nottingham 2004-01-29 11:31:36 EST
Some of this is cleaned up in 7.44-1.

Note You need to log in before you can comment on or make changes to this bug.