Bug 1145379 - Adding an entry with an invalid password as rootDN is incorrectly rejected
Summary: Adding an entry with an invalid password as rootDN is incorrectly rejected
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base   
(Show other bugs)
Version: 6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-23 01:04 UTC by Noriko Hosoi
Modified: 2015-07-22 06:35 UTC (History)
5 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-51.el6
Doc Type: Bug Fix
Doc Text:
Root DN (Directory Manager) and password administrators should bypass all password restrictions and syntax checks, but the checks were incorrectly applied. The bug was fixed and Root DN and password administrators have no restrictions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 06:35:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1326 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2015-07-20 17:53:07 UTC

Description Noriko Hosoi 2014-09-23 01:04:05 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47900

root DN, aka "cn=directory manager", should not be restricted by password policy.  During ADD operations the root DN is incorrectly restricted by password policy.  Updating an existing entry, doing a MOD, works as expected.

Comment 1 mreynolds 2014-09-30 19:21:19 UTC
Fixed upstream.

Comment 3 Noriko Hosoi 2015-02-20 00:37:18 UTC
Test case: dirsrvtests/tickets/ticket47900_test.py

Comment 4 Sankar Ramalingam 2015-03-11 13:06:02 UTC
Checked out the lib389 framework and executed the test case - 
ticket47900_test.py. The results shows the test case is passed. Hence, marking the bug as Verified.

[root@cloud-qe-14 PY.TEST]# rpm -qa |grep -i 389-ds-base
389-ds-base-1.2.11.15-52.el6.x86_64

  % (passwd, e.message['desc']))
INFO:lib389:Password update failed as expected: password (2_Short) result (Constraint violation)
INFO:lib389:Password update failed as expected: password (No_Number) result (Constraint violation)
INFO:lib389:Password update failed as expected: password (N0Special) result (Constraint violation)
INFO:lib389:Password update failed as expected: password ({SSHA}bBy8UdtPZwu8uZna9QOYG3Pr41RpIRVDl8wddw==) result (Constraint violation)
INFO:lib389:Activate Password Administator and try updates again...
INFO:lib389:Password update succeeded (2_Short)
INFO:lib389:Password update succeeded (No_Number)
INFO:lib389:Password update succeeded (N0Special)
INFO:lib389:Password update succeeded ({SSHA}bBy8UdtPZwu8uZna9QOYG3Pr41RpIRVDl8wddw==)
PASSED

Comment 5 errata-xmlrpc 2015-07-22 06:35:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1326.html


Note You need to log in before you can comment on or make changes to this bug.