Bug 114541 - After upgrade the printer will output only PCL XL errors.
After upgrade the printer will output only PCL XL errors.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
1
athlon Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 07:30 EST by Ivo Sarak
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-04 16:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'printconf-tui --Xexport' (2.61 KB, text/plain)
2004-01-29 11:48 EST, Ivo Sarak
no flags Details

  None (edit)
Description Ivo Sarak 2004-01-29 07:30:53 EST
Description of problem:
Somehow my Minolta PagePro 1100 has lost ability to print out anything
meaningful under Fedora Core 1 - only various PCL XL errors.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.79-1

How reproducible:
I haven't tried to reinstall the box, but at current state - always.

Steps to Reproduce:
1. Upgrade to FC1;
2. Get the printing working;
3. Upgrade the system with up2date for some time;
  
Actual results:
After upgrade to FC1 and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=111724 I got it
printing, but month or two later, only thing I get out of this printer
are various statements about PCL XL errors.

Expected results:
Printing as usual.

Additional info:
Nothing will appear to screen, the errors are printed to paper instead
of what I want to print:
1. CUPS TEST PAGE:
PCL XL error
    Subsystem: VECTOR
    Error: ExtraData
    Operator: LineRelPath
    Position: 62
2. A4 POSTSCRIPT TEST PAGE:
PCL XL error
    Subsystem: TEXT
    Error: IllegalFontSegment
    Operator: ReadFontHeader
    Position: 61
3. JPEG TEST PAGE:
PCL XL error
    Subsystem: KERNEL
    Error: IllegalTag
    Operator: 0xfd
    Position: 8
4. Try from Evolution:
PCL XL error
    Subsystem: KERNEL
    Error: IllegalTag
    Operator: 0xfe
    Position: 17


Removing and reinstalling the printer or using different driver will
get me the same or no result at all.

I do not remember what broke the printing...

What component is faulty?
Comment 1 Tim Waugh 2004-01-29 07:44:34 EST
You say you have been using up2date, but
redhat-config-printer-0.6.79-1 is not the latest available update for
Fedora Core 1.  Is that really the version you have got installed?
Comment 2 Ivo Sarak 2004-01-29 07:56:17 EST
Yes, it is not the latest redhat-config-printer around, but I
mentioned up2date in sence that the system has been updated for some time.

I'll launch up2date to get the latest redhat-config-printer.
Comment 3 Ivo Sarak 2004-01-29 08:11:31 EST
Quick up2date and reboot - now running redhat-config-printer-0.6.79.2-1.
No changes at all. Removed the printer and reinstalled it with
redhat-config-printer:
1. US Letter format - 
PCL XL error
    Subsystem: KERNEL
    Error: IllegalTag
    Operator: 0xe
    Position: 24
2. A4 format -
PCL XL error
    Subsystem: KERNEL
    Error: IllegalTag
    Operator: 0x6
    Position: 11

I see a KERNEL mentioned here, is the error coming from somewhere else
than redhat-config-printer?
Comment 4 Tim Waugh 2004-01-29 08:19:02 EST
Well that message is coming from your printer I think.

The reason I wanted to make sure you had up-to-date packages is
because I'd like you to try the test update packages here:

http://www.redhat.com/archives/fedora-test-list/2004-January/msg00120.html
http://www.redhat.com/archives/fedora-test-list/2004-January/msg00163.html
http://www.redhat.com/archives/fedora-test-list/2004-January/msg00293.html

Could you try doing that please, and let me know what the effect is? 
Thanks.
Comment 5 Ivo Sarak 2004-01-29 11:22:15 EST
I upgraded to:
foomatic-3.0.0-21.2.i386.rpm          gimp-print-devel-4.2.6-2.i386.rpm
ghostscript-7.07-15.1.i386.rpm        gimp-print-plugin-4.2.6-2.i386.rpm
ghostscript-devel-7.07-15.1.i386.rpm  gimp-print-utils-4.2.6-2.i386.rpm
gimp-print-4.2.6-2.i386.rpm           hpijs-1.5-4.1.i386.rpm
gimp-print-cups-4.2.6-2.i386.rpm

And the results are the same:
PCL XL error
    Subsystem: KERNEL
    Error: IllegalTag
    Operator: 0x4c
    Position: 22

Is there anything I should look up and post here?
Comment 6 Tim Waugh 2004-01-29 11:29:58 EST
Okay, it was worth a shot.  Can you please attach the output of
'printconf-tui --Xexport', so that I know exactly which driver is
responsible and what options are used?  Thanks.
Comment 7 Ivo Sarak 2004-01-29 11:48:11 EST
Created attachment 97341 [details]
'printconf-tui --Xexport'
Comment 8 Tim Waugh 2004-01-29 12:13:54 EST
So the pxlmono output is what the printer is complaining about. 
Actually this seems to be mentioned at www.linuxprinting.org:

http://www.linuxprinting.org/show_printer.cgi?recnum=Minolta-PagePro_1100

(see 'pxlmono' entry under 'Driver information').

Perhaps try the ljet4 driver instead?
Comment 9 Ivo Sarak 2004-01-29 13:04:38 EST
I tried with other drivers, but the result is no better at all - it
will start printing graphics, but will print random ascii symbols to
the mix and it will fail completely after printing 1/4 of CUPS testpage.

So, basically I get mixed text and graphics out of it.

What does this mean?
Comment 10 Tim Waugh 2004-01-30 05:01:19 EST
Can you think of any changes you made in between the time it was
working and the time it first didn't?  Were there any firmware
upgrades made to the printer?  In fact, are there any firmware
upgrades available for this printer?  Do you know the date that it
first gave this error (perhaps I can correlate it with a released FC1
update)?

It sounds a bit like it might be a problem with that model of printer,
since others have noted the same sort of errors with that model, but
pxlmono works fine for other printers.  But as you had it working at
one stage we would need to know what changed since then.
Comment 11 Ivo Sarak 2004-01-30 14:55:42 EST
I have never upgraded the firmware of this printer nor look if there
is any.

I do not print very often, but I vaguely remember last successful
printing 2..4 weeks ago.

Initial FC1 came to this box from upgrade from RedHat 9 and it may be
contributor of successful printing, but I can reinstall the system
from scratch to another harddrive and test it.

Maybe ther is a up2date trace I can look for?
Comment 12 Ivo Sarak 2004-01-31 16:52:14 EST
I installed the FC1 to another hdd and the result is the same - PCL XL
errors with pxlmono and partial page with other drivers. I'll install
a RedHat Linux 9 and upgrade from there.

I wonder if the printer itself is somehow went bad... What other
hardware components may cause this kind of problems? Paralel port faulty?
Comment 13 Ivo Sarak 2004-02-01 07:55:12 EST
I have something here - I connected the printer to another box and
enabled an ECP for parallel port in BIOS and I can print now with any
driver under FC1.
I'll have to put the printer back to the first computer and enable the
ECP. If this will resolve the issue then the case can be considered as
closed.
Comment 14 Tim Waugh 2004-02-04 07:55:26 EST
ECP really shouldn't make any different here -- our kernels don't use
ECP transfers for printers.
Comment 15 Ivo Sarak 2004-02-04 10:11:50 EST
Actually I enabled both EPP+ECP, but I suspect the ECP enabling made
it working.
Comment 16 Tim Waugh 2004-02-04 10:16:29 EST
So parallel ports have different modes available in the BIOS settings:

'Bi-directional'
'EPP'
'ECP'
'EPP+ECP'

They are *all* different from each other.  But for printing, there
should be no difference between them at all.

Please can you confirm that it does make a difference when you change
that setting on the original machine?
Comment 17 Ivo Sarak 2004-02-04 14:13:53 EST
I have following parallel port settings available in Asus SK8N BIOS:
1. Normal
2. EPP
3. ECP
4. EPP+ECP

I conducted some printing:
1. EPP+ECP, version 1.9, port 378, DMA3, IRQ7:
printing OK;
2. ECP, port 378, DMA3, IRQ7:
printing OK;
3. EPP, version 1.9, port 378, IRQ7:
printing OK;
4. Normal, port 378, IRQ7:
"PCL XL error"
Comment 18 Tim Waugh 2004-02-04 16:02:34 EST
If you're running a Red Hat-built kernel, this looks like a chipset bug.
Comment 19 Ivo Sarak 2004-02-05 09:39:31 EST
Yes, it is RedHat-built kernel.

Note You need to log in before you can comment on or make changes to this bug.