Bug 114544 - Upgrade to latest version
Upgrade to latest version
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gettext (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 08:02 EST by Tim Waugh
Modified: 2007-04-18 13:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-01 01:06:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-01-29 08:02:54 EST
Description of problem:
The version of gettext in rawhide is incompatible with the version of
automake we have.  The Makefile.in.in wants to use mkinstalldirs which
no longer exists, for example.  Perhaps it's fixed upstream?

How reproducible:
100%

Steps to Reproduce:
1. Grab http://cyberelk.net/tim/data/eggcups/eggcups-0.0.4.tar.bz2
2. ./bootstrap && ./configure && make distcheck on FC1+updates
3. Try again on rawhide
Comment 1 Tim Waugh 2004-01-30 05:09:31 EST
Discussed on fedora-devel-list:

http://www.redhat.com/archives/fedora-devel-list/2004-January/msg01750.html

Solution will be to create automake17 package.
Comment 2 Jens Petersen 2004-02-01 20:12:23 EST
Yes. gettext-0.14.1 still requires mkinstalldirs, so upgrading
won't actually solve this problem, but probably wouldn't do any
harm.

http://www.redhat.com/archives/fedora-devel-list/2004-January/msg01794.html

The solution is just to make the bootstrap script copy mkinstalldirs
into the source tree as needed.  The gettext maintainer recommends
either using autopoint or cp for this when using Automake 1.8.,
whereas Automake 1.7 does this for one.

[IMHO bootstrap should be run on the clean cvs check out before it
 is tar.gz'ed up, ie the tarball should include the mkinstalldirs
 file, but perhaps I'm old-fashioned.]
Comment 3 Tim Waugh 2004-02-02 04:42:04 EST
Automake-1.8 certainly did *not* run autopoint for me in the case of
eggcups -- I'm using AM_GLIB_GNU_GETTEXT there though.  I have now
modified the bootstrap script to run autopoint.

Of course eggcups was tarballed using './bootstrap; ./configure; make
distcheck' as always -- but I had to do it on a Fedora Core 1+updates
machine for 0.0.4.
Comment 4 Leon Ho 2004-02-02 22:34:53 EST
Anyway, I have rebuilt gettext to 0.14.1 on fc2-head.

Tim, do you happy with the solution which create the automake17 pkg? 
Comment 5 Tim Waugh 2004-02-03 04:48:24 EST
Yes.  I think automake17 will be needed sooner or later anyway.
Comment 6 Jens Petersen 2004-02-04 20:23:30 EST
Yep, because of 

http://www.redhat.com/archives/fedora-devel-list/2004-February/msg00202.html

automake17 is going to be added anyway.
Comment 7 Leon Ho 2004-04-01 01:06:16 EST
Closing now.

Note You need to log in before you can comment on or make changes to this bug.