Bug 1145664 - livecd-iso-to-disk fails to write iso to disk: basename: missing operand
Summary: livecd-iso-to-disk fails to write iso to disk: basename: missing operand
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 21
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: F21BetaBlocker 1144040
TreeView+ depends on / blocked
Reported: 2014-09-23 13:13 UTC by Petr Schindler
Modified: 2014-10-03 14:05 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-10-03 14:05:26 UTC
Type: Bug

Attachments (Terms of Use)
output of livecd-iso-to-disk (32.34 KB, text/plain)
2014-09-23 13:13 UTC, Petr Schindler
no flags Details

System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1144040 0 unspecified CLOSED "vesamenu.c32: not a COM32R image" when converting i686 images 2021-02-22 00:41:40 UTC

Internal Links: 1144040

Description Petr Schindler 2014-09-23 13:13:03 UTC
Created attachment 940428 [details]
output of livecd-iso-to-disk

Description of problem:
livecd-iso-to-disk fails to write iso to disk. Firstly I clear usb (with dd) then I run: livecd-iso-to-disk --format --reset-mbr Fedora-Server-netinst-i386-21_Alpha.iso /dev/sdb

this ends up with following error:
basename: missing operand

I add 'set -v' and 'set -x' to script and this is what happens right before it fails:
+ '[' -e /sys//devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/host7/target7:0:0/7:0:0:0/block/sdb/sdb1/device ']'
+++ readlink -f /sys//devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/host7/target7:0:0/7:0:0:0/block/sdb/sdb1/../
++ basename
basename: missing operand

You can find the whole output attached.

Version-Release number of selected component (if applicable):

How reproducible:
always after with clean usb disk

Steps to Reproduce:
1. clear usb (with gnome-disks or dd)
2. run 'livecd-iso-to-disk --format --reset-mbr SOME_ISO.iso /dev/sdb'

Actual results:
basename don't get operand

Expected results:
It should continue

Additional info:
When I put sleep 10 right before the line where this happens it continues (but fails sometime later)

Comment 1 Kamil Páral 2014-09-23 13:51:03 UTC
Just a note, the same error occurs also with Workstation Live i686, not just Server netinst i386 (both Alpha RC1).

Comment 2 Kamil Páral 2014-09-23 13:55:32 UTC
This is probably a Beta blocker for the same reason I proposed bug 1144040:
"Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."

I guess it applies to F21 host (converting the image) as well.

One more note, the fact that adding "sleep" to the script changes behavior, it seems that this is a race condition that became very frequent lately, probably triggered by some update. That means, unfortunately, that not everyone has to be able to observe this issue, or not that frequently.

Comment 3 Bruno Wolff III 2014-09-24 15:56:34 UTC
I did a reboot without rhgb or quiet and the last entry was:
reboot machine restart

The other thing I saw today was a hang with a non-live reboot on the same machine. This was also F21, but with a 3.17 kernel.There was not a systemd update betwwen the boot and reboot. (Systemd updates often cause reboot hangs.) There wasn't any log of the shutdown. The mouse pointer froze imediately and I had to power off before I could reboot. That is different than what I was seeing with the live image reboot hangs. So this might be something separate.

Comment 4 Bruno Wolff III 2014-09-24 15:58:40 UTC
Ignore my last comment, that was supposed to be for another livecd-tools bug.

Comment 5 Petr Schindler 2014-10-03 14:05:26 UTC
I tried it again today on various machines and it doesn't happen now. It seems that it is related to my problems with microcod-ctl (or maybe it was hardware problem). I'm closing this bug. If I will reproduce this again I will open it again.

Note You need to log in before you can comment on or make changes to this bug.