Bug 114581 - in text mode installer causes OverflowError in process_text.py method setPackageScale
in text mode installer causes OverflowError in process_text.py method setPack...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
other Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 13:45 EST by Peter Hurt
Modified: 2007-04-18 13:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 09:52:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hurt 2004-01-29 13:45:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; I)

Description of problem:
When attempting to install RedHat9 on a bochs2.1 emulator, the text 
installer crashes durring RPM installation.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1) Installed Bochs21.
2) configured startup script for network card, flat c.img file, and 
directly referanced D: as the the cdrom
3) configured startup script to boot to cdrom
4) configured the emulated NE2k netowrk card
5) installed from the CD in the cd-rom drive (RedHat9-disk1)
6) the emulated vgs and monitor interfaces aren't recognized, so the 
installed falls back to text mode
7) selected a typical Server configuration
8) after installing several RPMs the installer throws an error, and 
aborts the installatio

Actual Results:  Trackstack (most recient call last):
  File "/usr/bin/anaconda", line 739, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 459, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 255, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 817, in doInstall
    problems = ts.run(cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 359, in cb
    self.progress.setPackageScale(amount, total)
  File "/usr/lib/anaconda/textw/progress_text.py", line 55, in 
setPackageScale
    self.s.set(int(((amount * 1.0)/ total) * 100))
  OverflowError: float too large to convert

Kicking this into Debug and investigating the amount and total 
variables results in:
> /usr/lib/anaconda/textw/process_text.py(55)setPackageScale()
-> self.s.set(int(((amount * 1.0)/ total) * 100))
(Pdb) p total
2347440
(Pdb) p amount
2240824
(Pdb) p ((amount * 1.0)/ total) * 100
95.458201274579963
(Pdb) p int(((amount * 1.0)/ total) * 100)
95
(Pdb) c

This then continues and returns an error, causing the install to be 
aborted.


Expected Results:  Succesful RPM installation for the selected 
modules.

Additional info:

After several attempts, there appears to be no pattern as to which RPM 
is being installed when anaconda crashes. This has typically occured 
arround 30% overall completion, so several RPMs are successfully 
installed before the crash.
Comment 1 Jeremy Katz 2004-01-29 16:21:09 EST
With it being largely random, this sounds a lot like a "hardware"
problem.  Also, does it happen with FC1?
Comment 2 Peter Hurt 2004-02-05 09:52:45 EST
Since the exact same python statments run successfully in the 
debugger, and don't produce the Overflow Error... you're most likely 
correct. The bochs files do indicate extensive work was being done in 
the FPU for the 2.1 version, so it may take it a bit longer to 
mature. There was also a documented case in one of the MMX OP-codes 
that produced a race condition that could result in a floating point 
overflow. (Thought I'm not sure why the text version of the anaconda 
installer would be using the MMX op-cdes, but... it's possible.)

Yes, the Fedora Core install produced the same results, only at 47% 
rather than around 30% completion. But it to aborted dussing the RPM 
install. Unlike the shrike install, it did not give me the option to 
debug the error, nor did it give me any actual error text. It just 
stopped processing and unmounted the filesystem. But it's most likely 
a simular problem with the bochs system.

I'll continue to persue the "hardware issue", but at present this 
doesn't look like a RedHat problem.

Thanks for the help.
Comment 3 Peter Hurt 2004-02-23 10:37:12 EST
As follow up to this chain...
Bochs has released a 2.1.1 patched version, this does include an 
overload issue fix that appears to address this "hardware" problem, 
as FC1 does successfuly install when this version is used.

Note You need to log in before you can comment on or make changes to this bug.