Bug 114587 - libgdk-1.2 has undefined symbols
libgdk-1.2 has undefined symbols
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk+ (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 14:49 EST by Dan Gailey
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 15:15:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Gailey 2004-01-29 14:49:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
There are some weird errors I don't understand. 

[root@localhost mutella-0.4.1]# LinNeighborhood
LinNeighborhood: relocation error: /usr/lib/libgdk-1.2.so.0: undefined
symbol: XListInputDevices


make[2]: Entering directory `/tmp/aMule-1.2.4/src'
g++  -g     -o amulecmdDLG  amulecmdDLG-TextClient.o
amulecmdDLG-MD5Sum.o -pthread -lwx_gtk-2.4 -lcurl -L/usr/kerberos/lib
-lssl -lcrypto -lgssapi_krb5 -lkrb5 -lcom_err -lk5crypto -lresolv -ldl
-lz -L/usr/kerberos/lib -lz -lssl -lcrypto -lssl -lcrypto
-lgssapi_krb5 -lkrb5 -lcom_err -lk5crypto -lresolv -ldl -lz -lz
/usr/lib/libgdk-1.2.so.0: undefined reference to `XGetDeviceMotionEvents'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XFreeDeviceList'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XQueryDeviceState'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XListInputDevices'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XFreeDeviceMotionEvents'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XFreeDeviceState'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XOpenDevice'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XSelectExtensionEvent'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XUngrabDevice'
/usr/lib/libgdk-1.2.so.0: undefined reference to `XGrabDevice'
collect2: ld returned 1 exit status
make[2]: *** [amulecmdDLG] Error 1
make[2]: Leaving directory `/tmp/aMule-1.2.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/aMule-1.2.4'
make: *** [all] Error 2


Version-Release number of selected component (if applicable):
gtk+-1.2.10-28.1

How reproducible:
Always

Steps to Reproduce:
1. try and run/compile something that uses Xlibs
2.
3.
    

Actual Results:  the errors above.

Expected Results:  things to run?

Additional info:

none
Comment 1 Owen Taylor 2004-01-29 15:15:19 EST
GTK+ programs must always be compiled with the results of
gtk-config --libs; your WxWindows install doesn't seem to
handle this correctly, and seemse to be using a hardcoded
set of dependency libraries that doesn't include libXi.
Comment 2 Rex Dieter 2004-09-08 11:29:41 EDT
FYI, to fix the problem, use the system libtool, adding
LIBTOOL=/usr/bin/libtool
to the
make
and
%makeinstall 
lines in the specfile.
Comment 3 Owen Taylor 2004-09-08 11:49:22 EDT
Using LIBTOOL=/usr/bin/libtool is always wrong, because it
won't match the configure script.

But anyways, if you believe that this isn't a WxWindows bug,
then please provide a more detailed diagnosis and reopen this
bug.
Comment 4 Rex Dieter 2004-09-08 11:56:00 EDT
OK, maybe the fix I suggested isn't the best, but IMO
/usr/lib/libgdk-1.2.so.0
still should not contain undefined references, and as-is, does not
properly link against -lXi -lXext -lX11 (though it tries, but some
weird libtool oddness makes it fail)

Note You need to log in before you can comment on or make changes to this bug.