Bug 1145952 - right click on the background locks mouse clicks
Summary: right click on the background locks mouse clicks
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 21
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F21BetaFreezeException
TreeView+ depends on / blocked
Reported: 2014-09-24 07:50 UTC by Branko Grubić
Modified: 2014-10-06 05:04 UTC (History)
12 users (show)

Fixed In Version: mutter-3.14.0-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-10-06 05:04:45 UTC
Type: Bug

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 737233 0 None None None Never

Description Branko Grubić 2014-09-24 07:50:19 UTC
This is a copy of the problem from upstream bugzilla!
Few people on IRC confirmed that this exist on their systems too.

Description of problem:
I'm using gnome-shell-3.13.92-1.fc21.x86_64 and I wanted to change a
background, I know there is a menu available, so I did right click on the
background, but nothing happened, so I tried alternative way then, and I
realized that mouse clicks are not working anymore, before restarting
everything I tried few things, and it worked, ctrl+alt+up/down works changes
workspaces, but no mouse clicks, and later I found the workaround, meta key to
go to overview mode, and when it is closed everything works again.
Also not sure is this intended, while writing this bug report, I retested it,
and looks like left (primary click) opens menu, not right click? But right
click still locks mouse clicks.

Not sure can this be related, but background which set up before I wanted to
change it was "animated"/time_changing default background for gnome.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 1 Fedora Blocker Bugs Application 2014-09-24 08:05:56 UTC
Proposed as a Blocker for 21-beta by Fedora user bitlord using the blocker tracking app because:


Comment 2 Vaidas Jablonskis 2014-09-24 09:21:48 UTC
I can confirm that this is happening for me as well. Mouse can be "unlocked" by going into overview.


Comment 3 Mike Ruckman 2014-09-24 21:38:30 UTC
Can't reproduce this in kvm.

Comment 4 Branko Grubić 2014-09-30 06:49:23 UTC
In upstream bug report it says it is fixed, I assume it will be released in next bugfix release, currently this affects final stable gnome-shell-3.14.0-2.fc21.x86_64 

(In reply to Mike Ruckman from comment #3)
> Can't reproduce this in kvm.

I cannot remember now, but I think some of the developers on IRC talked about some cases where it looks OK, you cannot hit this bug, I think when you only use one workspace and all windows are on it (or probably no programs opened at all). But I'm not 100% sure about this, I tested that case, and it really worked as expected. So maybe you tested it like that and you wasn't able to hit the bug.

Comment 5 Petr Schindler 2014-10-01 10:20:13 UTC
I'm not sure if I hit the same bug, but the exact thing happend to me too.

When I try to right click on the background on some workspace where I have some windows it opened the menu. Left click does nothing. But when I go to some empty workspace (on the bottom) and I click LEFT button the menu appears, but when I click right button, nothing happens and I can't use mouse clicks AND keyboard any more. Only thing I can do is to switch to console (ctrl+alt+f2) and restart gnome-shell.

I'm +1 for blocker.

Comment 6 Adam Williamson 2014-10-03 16:29:54 UTC
Discussed at 2014-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-10-03/f21-blocker-review.2014-10-03-15.58.log.txt . We agreed this doesn't quite meet any release criteria and the 'Start' workaround makes it relatively easy to break free if you hit it, but it's certainly annoying and we'd like to see it fixed ASAP. We also agreed to grant it FreezeException status - if, somehow, the fix doesn't make it in by freeze, we'd be OK with breaking freeze to fix it at least for the first few days.

Comment 7 Fedora Update System 2014-10-04 17:52:22 UTC
mutter-3.14.0-3.fc21 has been submitted as an update for Fedora 21.

Comment 8 Fedora Update System 2014-10-05 08:13:54 UTC
Package mutter-3.14.0-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mutter-3.14.0-3.fc21'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-10-06 05:04:45 UTC
mutter-3.14.0-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.