Bug 114600 - RFE: add Povides glibc-devel-i386
RFE: add Povides glibc-devel-i386
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 17:11 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 04:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-01-29 17:11:59 EST
Description of problem:
On the x86_64, building gcc reqires both the x86_64 glibc-devel and
the i386 glibc-devel so that gcc can generate both 32 bit and 64 bit code.

The current situation is that there is the build fails with no real
obvious reason why.

The problem was that the i386 glibc-devel as not installed.

This RFE requests the addition of a Provides to the glibc-devel
package of the sort:


%ifarch i386
Provides: glibc-devel-i386
%endif

This can then be used by gcc in such as:

%ifarch x86_64
Buildreq: glibc-devel-i386
%endif
Comment 1 Gene Czarcinski 2004-01-29 17:16:57 EST
See: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114601
Comment 5 Jakub Jelinek 2005-07-26 04:18:50 EDT
IMHO that's a bad idea and very ugly.  If anything, gcc's spec could have:
%ifarch %{multilib_64_archs} sparc ppc
BuildRequires: /lib/libc.so.6 /usr/lib/libc.so /lib64/libc.so.6
/usr/lib64/libc.so
%endif
and no changes are needed on the glibc side.

Note You need to log in before you can comment on or make changes to this bug.