Bug 114601 - RFE: add Buildreq for glibc-devel-i386
RFE: add Buildreq for glibc-devel-i386
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 17:16 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.0.1-5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 05:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-01-29 17:16:14 EST
Description of problem:
On the x86_64, building gcc reqires both the x86_64 glibc-devel and
the i386 glibc-devel so that gcc can generate both 32 bit and 64 bit code.

The current situation is that there is the build fails with no real
obvious reason why.

The problem was that the i386 glibc-devel as not installed.

Assuming than an addition has been mad to glibc-devel of the sort:


%ifarch i386
Provides: glibc-devel-i386
%endif

Then this RFE requests the additon of something like the following to
the gcc spec file:

%ifarch x86_64
Buildreq: glibc-devel-i386
%endif

See:https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114600
Comment 1 Jakub Jelinek 2005-08-18 05:25:55 EDT
gcc-4.0.1-5 and above has:
%ifarch %{multilib_64_archs} sparc ppc
# Ensure glibc{,-devel} is installed for both multilib arches
BuildRequires: /lib/libc.so.6 /usr/lib/libc.so /lib64/libc.so.6
/usr/lib64/libc.so
%endif

Note You need to log in before you can comment on or make changes to this bug.