Bug 114606 - SSL? not working with Linux 2.6 from http://people.redhat.com/arjanv/
SSL? not working with Linux 2.6 from http://people.redhat.com/arjanv/
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 21:24 EST by Keith McNeill
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 22:58:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keith McNeill 2004-01-29 21:24:07 EST
Description of problem:

I installed the linux 2.6 kernel from http://people.redhat.com/arjanv/
 on top of Fedora Core 1.  It seems to work fine except for certain
SSL connections within browsers.  I've tried Opera and Mozilla 1.6 and
can duplicate the problem.  If I go to webexpress.fidelity.com or
www.vanguard.com the browser just hangs.  I assume it is some sort of
problem with SSL because these URLs redirect you to a https site. 
Inerestingly if I go to https://www.microsoft.com things seem to work
ok.  If I do this in the Linux 2.4 fedora core kernel it all works
fine.  Fails with both the SMP and non-SMP kernel.

Machine is a Dell Inspiron 5150 with a 3.2 ghz P4 w/HT

Version-Release number of selected component (if applicable):
fedora core 1 with kernel-2.6.1-1.149.i686.rpm from
http://people.redhat.com/arjanv/ dated 1/27/04

How reproducible:
very

Steps to Reproduce:
1. boot linux 2.6
2. open mozilla
3. put in webexpress.fidelity.com
  
Actual results:
browser hangs...never see the login screen

Expected results:
see Fidelity login screen.

Additional info:
Comment 1 Dave Jones 2004-06-19 11:35:33 EDT
does it work if you disable ECN ? (echo 0 > /proc/sys/net/ipv4/tcp_ecn)

If not, is this still occuring in the current kernel ?
Comment 2 Keith McNeill 2004-11-19 09:18:33 EST
no longer a problem

Note You need to log in before you can comment on or make changes to this bug.