Bug 114617 - sa and lastcomm display wrong times
Summary: sa and lastcomm display wrong times
Status: CLOSED DUPLICATE of bug 89959
Alias: None
Product: Fedora
Classification: Fedora
Component: psacct   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Charlie Bennett
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-30 07:59 UTC by Herbert Gasiorowski
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Herbert Gasiorowski 2004-01-30 07:59:17 UTC
Description of problem:
When displaying the summary accounting report sa or the list of
accounting data with lastcomm the time-data is 10 times too high.

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2149.nptl
psacct-6.3.2-28

How reproducible:
Always

Steps to Reproduce:
1.run a program which eats some cputime:
   $ time testprog
   real    0m5.761s
   user    0m5.756s
   sys     0m0.004s
2.check the time with lastcomm:
   $ lastcomm testprog
   cryps                   gasi     stdout    57.61 secs Fri Jan 30     

Actual Results:  
The time shown by lastcomm (and sa) is 10 times the time of the
"time"-command

Expected Results:  Times should be the same


Additional info:

- sa and lastcomm use #define AHZ from /usr/include/acct.h which is
100 but should be 1000
- the same applies to kernel-source-2.6.1-1.61

Comment 2 Charlie Bennett 2004-04-07 17:50:49 UTC

*** This bug has been marked as a duplicate of 89959 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:01:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.